Hot end not working after upgrade to RR3



  • This line, you define the tool to use heater 1 which doesn't exist

    M563 P0 D0 H1 F0 ; define tool 0
    

    Try

    M563 P0 D0 H0 F0 ; define tool 0
    


  • @blt3dp
    Bad idea....



  • modified as suggested and still not functioning ....
    ; Heaters
    M140 H-1 ; disable heated bed (overrides default heater mapping)
    M308 S0 P"e0temp" Y"thermistor" T100000 B4138 C7.06e-8 R4700 ; configure sensor 0 as thermistor on pin e0temp
    M950 H1 C"e0heat" T0 ; create nozzle heater output on e0heat and map it to sensor 0
    M143 H1 S280 ; set temperature limit for heater 0 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for the nozzle heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H0 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C



  • @dingo007 said in Hot end not working after upgrade to RR3:

    M308 S0

    Check that too



  • @DIY-O-Sphere still no joy after modifying the config

    1/10/2020, 11:01:08 PM M292 P1
    Printing paused at X0.0 Y0.0 Z0.0
    1/10/2020, 11:01:06 PM Resume state saved
    Warning: Tool 0 was not driven because its heater temperatures were not high enough or it has a heater fault
    1/10/2020, 11:01:01 PM Error: Temperature reading fault on heater 1: unknown temperature sensor channel

    with config.g
    ; Heaters
    M140 H-1 ; disable heated bed (overrides default heater mapping)
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 C7.06e-8 R4700 ; configure sensor 0 as thermistor on pin e0temp
    M950 H1 C"e0heat" T0 ; create nozzle heater output on e0heat and map it to sensor 0
    M143 H1 S280 ; set temperature limit for heater 0 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for the nozzle heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H0 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C



  • @dingo007 said in Hot end not working after upgrade to RR3:

    M950 H1 C"e0heat" T0 ; create nozzle heater output on e0heat and map it to sensor 0

    change to T1.

    it would be easier if you did this in the configurator.



  • @Veti that configurator is too confusing, probably why i got where i am... and it was generated in RR config



  • @Veti

    Nope no joy.... maybe RR3 was abad idea 😞

    Printing paused at X0.0 Y0.0 Z0.0
    1/10/2020, 11:07:15 PM Error: Temperature reading fault on heater 1: unknown temperature sensor channel
    Resume state saved
    Warning: Tool 0 was not driven because its heater temperatures were not high enough or it has a heater fault

    config.g
    ; Heaters
    M140 H-1 ; disable heated bed (overrides default heater mapping)
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 C7.06e-8 R4700 ; configure sensor 0 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 0
    M143 H1 S280 ; set temperature limit for heater 0 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for the nozzle heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H0 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C



  • @DIY-O-Sphere

    What do you mean? He's was heater 0 as his hotend heater, his tool was set to use heater 1 all that I suggested was to tell the tool definition to use the correct heater.

    I do suppose you could change everything to heater 1 as was done, I would have just changed that one line to heater 0 instead.

    Looking at your current config, it should work.



  • Does this bother anyone else?? Current 2000.0c

    Screenshot_20200110_231158.png



  • @dingo007
    did you reststart after changing the config?



  • @Veti yes, i always restart after any edits.... even single character edits.



  • @dingo007
    2000 means there is no thermistor on that connector also delete the C

    also your thermistors values are incorrect.



  • @blt3dp
    Noone else would understand why H0 is used for the tool.
    To comply with conventions I think it's better not to do that.



  • @Veti

    working RR2 config.g
    ; Heaters
    M140 H-1 ; disable heated bed
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    non-working RR3 config.g
    ; Heaters
    M140 H-1 ; disable heated bed (overrides default heater mapping)
    M308 S0 P"e0temp" Y"thermistor" T100000 B4138 R4700 ; configure sensor 0 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 0
    M143 H1 S280 ; set temperature limit for heater 0 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for the nozzle heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H0 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C



  • ; Heaters
    M140 H-1 ; disable heated bed (overrides default heater mapping)
    M308 S0 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin e0temp
    M950 H0 C"e0heat" T0 ; create nozzle heater output on e0heat and map it to sensor 0
    M143 H0 S280 ; set temperature limit for heater 0 to 280C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the nozzle heater and set PWM limit

    ; Tools
    M563 P0 D0 F0 ; define tool 0

    add it this way



  • @Veti said in Hot end not working after upgrade to RR3:

    M563 P0 D0 F0 ; define tool 0

    sorry
    M563 P0 D0 H0 F0 ; define tool 0

    seems there is a problem with the configurator.



  • @Veti said in Hot end not working after upgrade to RR3:

    M563 P0 D0 H0 F0 ; define tool 0

    1/10/2020, 11:38:54 PM Printing paused at X0.0 Y0.0 Z0.0
    1/10/2020, 11:38:52 PM Resume state saved
    Warning: Tool 0 was not driven because its heater temperatures were not high enough or it has a heater fault
    1/10/2020, 11:38:47 PM Error: Temperature reading fault on heater 0: unknown temperature sensor channel

    config.g - edited as you said.
    ; Heaters
    M140 H-1 ; disable heated bed (overrides default heater mapping)
    M308 S0 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin e0temp
    M950 H0 C"e0heat" T0 ; create nozzle heater output on e0heat and map it to sensor 0
    M143 H0 S280 ; set temperature limit for heater 0 to 280C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the nozzle heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H0 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H0 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C



  • you are on rrf 3.0 and not a beta or a rc?



  • @Veti whatever rr config gave me when i selected 3.0



  • whats the output of M115?



  • @Veti yeah thats the problem, is it not included in config.zip ?

    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.04 ELECTRONICS: Duet Ethernet 1.02 or later FIRMWARE_DATE: 2019-11-01b1



  • @Veti great so i downloaded the proper file and uploaded it to the gui
    was prompter to install the latest firmware, i said yes and got this

    M997 S0
    Error: M997: In-application programming binary "iap4e.bin" not found



  • Is that file showing in your sys directory where your config.g is at? If not, you can get it from the Duet2Firmware-2.04.zip listed under assets at this link.

    https://github.com/dc42/RepRapFirmware/releases/tag/2.04



  • @blt3dp already fixed that 🙂 thanks


Log in to reply