Cannot set hot end temp in DWC



  • Short sweat background / config. I have a new Duet 2 Wifi, Duet Web Control 2.0.4. I have a CoreXY machine. I have an E3D v6. The hotend does heat up. The heated bed has no issues.

    When attempting to set the temperature for the hotend in the Duet Web Control (DWC) it does not activate the hotend. I have attempted with the drop down's preset values, I have tried typing in my own and pressing enter. I am able to get the hotend to start heating by issuing a console command, i.e., M104 H1 S245 (this is the most reliable method) or by going to the "Control All" menu and setting a temp in the "Set all active temperatures" (this also hits the heated bed setting and gives an error that 245, etc. is too high for this heater - this is to be expected). When typing the temp I want into the hotend active temp I sometimes get a message to type in a valid number, again I am typing in 245 or 250 or 190.

    I also have Simplify3D so I connected that via USB to see what it did. Long story short I kind of get the same problem accept I cannot use the M104 command, nothing happens. I set the temp and tool to T0 then click "Set" button, nothing, I then change drop down to T1 and without doing anything else the hotend pops on and heats.

    I have not setup my panel yet so I haven't tried that method.

    Here is my config.g file:

    ; TronXY X5S config file for Duet 2 WiFi firmware 2.05
    
    ; Prologue and  comms section
    M111 S0							; Debug off
    M550 PTronXY X5S					; Machine name (can be anything you like)
    ;M551 Preprap						; Machine password
    M555 P2							; Set output to look like Marlin
    M575 P1 B57600 S1					; Comms parameters for PanelDue
    
    ; Networking Section
    ;*** If you have more than one Duet on your network, they must all have different MAC addresses, so change the last digits
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED			; MAC Address
    ;*** Adjust the IP address and gateway in the following 2 lines to suit your network
    M552 S1							; Enable WiFi module
    M552 P10.201.230.26					; IP address (0 = use DHCP)
    M554 P10.201.230.3					; Gateway
    M553 P255.255.255.0					; Netmask
    M586 P0 S1						; Enable HTTP
    M586 P1 S0						; Disable FTP
    M586 P2 S0						; Disable Telnet
    
    ; Movement section
    M667 S1							; Select CoreXY mode
    G90							; Send absolute coordinates...
    M83							; ...but relative extruder moves
    M569 P0 S1						; Drive 0 goes (S1 = forwards S0 = reverse)
    M569 P1 S1						; Drive 1 goes (S1 = forwards S0 = reverse)
    M569 P2 S0						; Drive 2 goes (S1 = forwards S0 = reverse)
    M569 P3 S0						; Drive 3 goes (S1 = forwards S0 = reverse)
    ;M569 P4 S0						; Drive 4 goes (S1 = forwards S0 = reverse)
    M350 X16 Y16 Z16 E16 I1					; Configure microstepping with interpolation
    M574 X1 Y1 S0						; set endstop configuration (X and Y endstops only, at low end (1)-(2) would be high end, active low (S0)/active high (S1))
    M92 X80 Y80 Z400					; Set axis steps/mm
    M92 E96.45						; Set extruder steps per mm
    M566 X600 Y600 Z12 E120					; Minimum speeds mm/minute
    G21							; Work in millimetres
    M906 X1000 Y1000 Z1000 E1100 I30			; Set motor currents (mA) and motor idle factor in percent
    M201 X3000 Y3000 Z100 E10000				; Accelerations (mm/s^2)
    M203 X18000 Y18000 Z1800 E1500				; Maximum speeds (mm/min)
    M84 S30							; Set idle timeout
    M592 D0 A0.015 B0.0012 L0.2				; Extruder nonlinear adjustment
    
    ;Axis Limits
    M208 X0 Y0 Z0 S1					; set axis minimum (adjust to make X=0 and Y=0 the edge of the bed)
    M208 X305 Y262 Z395					; set axis maximum (adjust to suit your machine)
    
    ; Z probe section
    ;M558 P1 X0 Y0 Z1 H3 F200 T5000				; Smart IR Z probe, used for homing Z axis, dive height 3mm, probe speed 200mm/min, travel speed 5000mm/min
    ; BLTouch
    M574 Z1 S2						; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1					; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F500 T4000 X0 Y0 Z1				; Set Z probe type to bltouch (P) and the dive height (H) + speeds(F-up/down) (T move between probepoints) Not using on XY, but on Z
    G31 P25 X12 Y82.5 Z0.0				; Set Z probe trigger value, offset and trigger height
    M557 X60:280 Y80:180 S20				; Define mesh grid for bed leveling
    
    ; Heater, Fan, and thermistor section
    ;*** If you have a Duet board with 1K thermistor series resistors, change R4700 to R1000 to the following M305 commands
    M305 P0 T100000 B4138 C0 R4700			; Set thermistor + ADC parameters for heater 0 
    M143 H0 S90						; Set temperature limit for heater 0 (bed) to 90C
    M305 P1 T100000 B4138 C0 R4700				; Set thermistor + ADC parameters for heater 1
    M143 H1 S250						; Set temperature limit for heater 1 (hot end) to 250C
    M106 P0 S0 I0 F500 H-1					; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45			; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45				; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M307 H1 A459.4 C167.2 D4.1 S1.00 V0.0 B0		; PID for Extruder
    M307 H0 A72.6 C353.1 D2.8 S1.00 V12.1 B0		; PID for Bed
    
    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000"	; Set voltage thresholds and actions to run on power loss
    
    ; Tool definition section
    M563 P0 D0 H1 S"Extruder"				; Define tool 0
    G10 P0 X0 Y0 Z0						; Set tool 0 axis offsets
    G10 P0 R0 S0						; Set initial tool 0 active and standby temperatures to 0C
    ;*** If you have a dual-nozzle build, un-comment the following 2 lines
    ;M563 P1 D1 H2						; Define tool 1
    ;G10 P1 S0 R0						; Set tool 1 operating and standby temperatures
    
    ; Custom settings are not configured
    M671 X1:160:323.5 Y0:0:315.5 P8	; adjusting screws at rear left (-15,190), front middle (100,-10) and rear right (215,190), thread pitch 8mm
    M572 D0 S0.1						; Set pressure control to 0.1
    
    ; Epilogue
    ;*** If you are using axis compensation, put the figures in the following command
    ;M556 S78 X0 Y0 Z0					; Axis compensation here
    T0							; select first hot end
    code_text
    

    Any help will be appreciated.



  • @StudioForge You need to select a tool first. Just send T0, or have T0 in your slicer start gcode or at the end of your config.g. That's why the M104 worked after you sent T1 but wouldn't work before any Tn command.



  • In S3D or in DWC?



  • Sorry if I sound dumb, but I am just ignorant. I sent "T0" in both DWC and S3D and then tried to set hotend temp. Nothing happened.



  • @StudioForge I've just looked more closely at your OP and I think it's because you are using an H parameter which isn't necessary. Try selecting a tool then sending M104 Snnn or you can do both together by using the format M104 Tn Snnn.



  • OK so if I throw "M104 T0 Sxxx" via the console in DWC or S3D hotend comes alive. In DWC both the active and stand by temps are set to the target temp. In S3D both the Set and Off buttons function correctly. So how do I get S3D to work correctly from a cold boot of the printer without having to first send a command via console, and how do I get DWC GUI to work?



  • Not sure if this is related, if I preheat my printers, setting the bed temperature first and I set the hotend to 235c (and above), the hotend does not start heating until the bed reaches set temperature.



  • @bricor My guess would be that you are using M190 to set the bed temperature and wait for it to be reached. Use M140 instead and add M116 after setting the hot and temperature.



  • @StudioForge I don't use S3D but as a general rule, you need to put the necessary commands in the slicer start gcode. BTW, the correct way to do this is to use G10 S and R but few slicers support this (although most will allow you to use that format in the start gcode).
    Not sure what you mean by getting the GUI to work. I'm 10,000 miles away from my printer and just have my 'phone in front of me but select a tool (make sure it's highlighted) try then click the active temperature box and select a temperature from the drop down list (or type in a number).



  • @deckingman thank you.
    I was describing the results I get when selecting from the presets in the DWC to preheat. I wasnt sure if the OP was experiencing the same.



  • @bricor Hmm. Maybe it's the case that DWC uses set and wait, rather than just set. Difficult for me to say as I'm on the other side of the world from my printer and just have my mobile at hand.



  • @bricor I am not experiancing what you are exactly. I am not able to set the temp in the Graphical User Interface of DWC and have the hotend start heating. I can set the bed temp. It doesn't matter if the bed is to temp or not I cannot set the hotend temp. I can only set the hotend temp via the console. If I use the Simplify3D console I have to send "T0" then the GUI buttons work.



  • @StudioForge I just tried it on one of my machines. After powering up, without setting the bed temperature, the first time I select a hotend temp (from the pulldown list thing in DWC) it starts heating right away. If I put the heater in Standby or turn it Off by using the Hyperlink "Heater1" under the "Heater" header in DWC, the next time I set the temperature using the pulldown list thing in DWC, I have to click on the same "Heater1" hyperlink to make the hotend active (start heating). The word underneath Heater1 changes, toggles between Active, Standby and Off each time you click it. Sorry if this is already known and obvious. Hopefully it helps.



  • @StudioForge That's normal behaviour. You have to select a tool before you can heat it. The simplest thing to do is add T0 to your config.g file (as long as you don't already have a G10 to set the active and standby temperatures to values other than 0 or -273).



  • @deckingman Ok, this is making more sense now. If I throw "T0" via console in DWC or S3D then selecting temp in GUI works. Am I just missing a button to select a tool in the DWC. I can click Heater 1 link and it cycles from active to stand by to off and then loops. I guess that is what needs to be done via GUI. Deckingman, I will put T0 at the end of my config.g file like you suggested, that makes sense.

    Thank you all for the interactions and advice. Perhaps there could be some tweaks done to the DWC GUI, but it is just more me learning it.

    Ok now how do I mark this as solved??



  • @StudioForge said in Cannot set hot end temp in DWC:

    Ok now how do I mark this as solved??

    Use 'Topic Tools' to 'Ask as question', then 'Mark as solved'. I think only the OP or an admin can do this. I did it for you!

    Ian



  • @StudioForge said in Cannot set hot end temp in DWC:

    ...................Am I just missing a button to select a tool in the DWC. I can click Heater 1 link and it cycles from active to stand by to off and then loops. I guess that is what needs to be done via GUI.............

    You're not missing a button - just click on the tool itself - not the heater. When you do that, the background will change colour then you can use the drop down to select an active temperature (or type in a value) and it will start heating. Set the active tempertaure to zero to stop heating.



  • @deckingman Holy crap! ok, thanks. I guess I should RTFM.