Duet2 Wifi Stopped Working



  • My Duet2 Wifi was working great. I am still in learning mode. Running some simple gcode. The last time I went to use it, it was unresponsive. I pulled the SD card and checked it in my laptop and it was unreadable.

    When powered on, the blue, red, and green LEDS are lit as well as the red diag LED is lit. When I plug the USB into my laptop, the USB power LED lights, but my laptop does not find any new hardware.

    I read the "What to do if your Duet won't respond" documentation and I am at a dead end. I have not yet put in a new SD card. I was not sure if that was needed to diagnose the problem.

    Any suggestions? Any help would be greatly appreciated.


  • Moderator

    Does the CPU get hot to the touch? Do you see any visible damage?



  • @SteveK42 said in Duet2 Wifi Stopped Working:

    I have not yet put in a new SD card. I was not sure if that was needed to diagnose the problem.

    As long as you removed the old as part of the "what to do" docs then adding a new won't give you any adittional information I'm affraid



  • @Phaedrux I turned it on and attached it to my laptop. I waited for 5 minutes and I the CPU did not get hot. How long should I wait? How hot does it get if there is an issue? I did not see any damage on the board.


  • Moderator

    @SteveK42 If the red diag light is on, particularly if the SD card has been removed, most likely the firmware has been erased or corrupted, or it's stuck in a boot loop (reset button stuck in, or some other short circuit/issue). I'd advise disconnecting all wiring from the Duet and trying to connect via USB again. Make sure you try a different USB cable; there are USB cables that only have power wires, not data. They are also often cheaply made, so it's worth finding one that you know works with another device.

    If the firmware is stuck, most likely you'll need to erase and reflash the firmware using Bossa. See https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_Fallback_procedure_Num_3

    To build a new SD card (either format your existing one if it is no longer readable, or get a new one), see https://duet3d.dozuki.com/Wiki/SD_Card for specification, and use file SD_Card_Contents.zip from https://github.com/T3P3/Duet/tree/master/Duet2/SD Card Contents to get a basic setup going.

    Ian



  • @droftarts Thank you for the suggestions. I tried two different USB cables and two different laptops. One of the cables was used with a spare raspberry pi that is currently not in use. The board does not show up in device manager. I also tried YAT, and it did not find it either, which I expected because the O/S did not see it.

    All wiring is disconnected, except for power. I did try to erase the board several times by putting a jumper on the erase pins as per the procedures documented. That did not help.


  • Moderator

    @SteveK42 It won't show if it's stuck in a boot loop; the USB never has time to initialise before it reboots. Check if the reset button is stuck in, or if there's a short circuit (eg metal filings) across the back of it.

    To erase the firmware with the erase pins, you need to jumper the pins, apply power for at least a couple of seconds, disconnect power, remove jumper. If the processor is not getting hot, and neither is the SD card socket, USB or Wifi board with power on for 30+ seconds, I don't think it should have failed, just something is stopping it booting correctly.

    Ian


Log in to reply