Unable to send any files to my Duet Wifi



  • This started out as a little annoyance, but now it has become a major problem. I can't get any files to transfer to my Duet Wifi. I had been sending files via PrusaSlicer but recently, those started to fail all the times. I then started using the Upload G-Code File button in the web interface. That was working for a bit, but now all files fail at different parts of the upload. I then tried using FileZilla to transfer files, but it fails too. So now I have no way of sending any files to my printer. I haven't tried pulling the SD card and transferring directly because the card is hard to access. I can't even upload new firmware. And now, after trying to update the firmware, I can't even access the web interface. 😞



  • I would guess your SD card is borked.
    Try a new one


  • administrators

    What is the reported WiFi signal strength in the M122 report?



  • @jay_s_uk Tried a new card. Same issue.



  • This post is deleted!


  • @dc42 When I was able to connect, it was -67 I believe. Since that message, things have gotten worse. I tried updating via Ponterface and it reports it can't write to the printer. The PanelDue still works and I can transfer files by writing directly to the card so I have been able to print. Going to try reflashing the board in a bit.



  • @dc42 When trying to update via USB through Ponterface, I get this...

    Connecting...
    RepRapFirmware for Duet 2 WiFi/Ethernet Version 2.05 dated 2019-12-13b1
    Executing config.g...FTP is enabled on port 21
    TELNET is enabled on port 23
    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 265C.
    Done!
    Printer is now online.
    >>>M115
    SENDING:M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.05 ELECTRONICS: Duet WiFi 1.02 or later + DueX5 FIRMWARE_DATE: 2019-12-13b1
    >>>M997 S0
    SENDING:M997 S0
    [ERROR] Can't read from printer (disconnected?) (SerialException): call to ClearCommError failed
    [ERROR] Can't write to printer (disconnected?) (SerialException): WriteFile failed ([Error 22] The device does not recognize the command.)
    [ERROR] Can't write to printer (disconnected?) (SerialException): WriteFile failed ([Error 22] The device does not recognize the command.)
    [ERROR] Can't write to printer (disconnected?) (SerialException): WriteFile failed ([Error 22] The device does not recognize the command.)
    [ERROR] Can't write to printer (disconnected?) (SerialException): WriteFile failed ([Error 22] The device does not recognize the command.)
    [ERROR] Disconnecting after 4 failed writes.
    Disconnected.
    


  • @ElmoC
    Have you got it in marlin emulation mode?
    See https://duet3d.dozuki.com/Wiki/Gcode#Section_M555_Set_compatibility



  • @jay_s_uk As far as I know I don't. It had been working fine but then problems started without making any changes to the config.g file. Next time I have the card out, I will check to be sure.

    UPDATE: I checked and it is set to make the OUTPUT look like Marlin, which it has always been set to. Nothing about emulation of Marlin.



  • So after flashing the firmware via BOSSA and updated the WiFi firmware via the PanelDue. Rebuilt the /www directory (note, the DuetWebControl.bin file is not in the release file), I was able to get the web interface back up. Need to try and send a file to it next.

    UPDATE: When I try testing the connection for PrusaSlicer, the web interface gets knocked off (Failed to maintain connection) and asks for the password. PrusaSlicer reports the test was successful.

    UPDATE 2: Still unable to upload files. Going to try to put a different AP on for the printer to use.



  • Adding a different access point allowed me to send a job from PrusaSlicer. Will have to see how long this will work.



  • And I can't upload again. 😞

    FTP also fails.



  • @ElmoC Have you tried running the Duet in Access Point mode? Not as convenient as connecting it to your network, but might show if the issue is with the Duet or your network. See https://duet3d.dozuki.com/Wiki/Gcode#Section_M589_Configure_access_point_parameters

    Ian



  • This post is deleted!

Log in to reply