Maestro, RRF3 and BLTouch issues



  • I have just upgraded my Maestro to RRF3, fresh SD card fresh config created using the tool.
    Tweaked the config for my upgrades, Z axis, DirectDrive Extruder.

    My issue is now I cannot home Z, the probe does not even deploy.
    From power up the probe does its selftest and it was working 1hr ago in rrf2.5

    I have just checked the download from the configtool and there are NO deployprobe or retractprobe files, like I had before.

    I attach my config.g, just incase something is wrong in that

    config.g

    Your assistance would be appreciated.

    Regards,
    Paul



  • post your deploy and retractprobe



  • @Veti Thanks for replying.
    There are no deploy and retract files in the download from the configtool

    P.



  • it does generate them for me

    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Fri Jan 17 2020 14:22:08 GMT+0100 (Central European Standard Time)
    M280 P0 S10 ; deploy BLTouch

    ; retractprobe.g
    ; called to retract a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Fri Jan 17 2020 14:22:16 GMT+0100 (Central European Standard Time)
    M280 P0 S90 ; retract BLTouch



  • Thank you, I will create them manually and let you know.



  • you might have to invert the the mod pin also
    M950 S0 C"^!zprobe.mod" ; create servo pin 0 for BLTouch


  • administrators

    @Veti said in Maestro, RRF3 and BLTouch issues:

    you might have to invert the the mod pin also
    M950 S0 C"^!zprobe.mod" ; create servo pin 0 for BLTouch

    You don't need to invert it.



  • Created the files, again, thanks.
    X and Y are fine, Z just moves up a bit but does not deploy the probe and goes blue to indicate the Z axis is homed.

    Have inverted the signal as suggested but no difference, the probe does not deploy.

    I will take the inversion out then! Thanks @dc42

    P.



  • post your homeall.g

    also your config.g is missing
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    this config looks like you did not select the bltouch in the configurator.



  • I put the m574 line in and Z axis goes up then down but no probe deploy.
    I have to use emergency stop.

    homeall.g as requested.

    Paul.



  • your home scripts are not for a probe.

    please return to the configurator and select a z-probe the z endstop and recreate everything.



  • I did as Veti asked and created the config again.
    I did post an issue in regards to the configurator yesterday as it is complicated in trying to use the Ender3 template and creating an RRF3 config with BLTouch. However.....

    I think I have found the problem.

    I found this in the Gcode bible. https://duet3d.dozuki.com/Wiki/Gcode#Section_M558_in_RepRapFirmware_Num_3

    "Example 3 (BLTouch on Duet Maestro) - old code:

    M558 P9 H5 F120 T3000 ; BLTouch connected to Z probe IN pin
    ...
    M280 P64 S10 ; send control signal to BLTouch through Z probe MOD pin

    New code:

    M558 P9 C"zprobe.in" H5 F120 T3000 ; BLTouch connected to Z probe IN pin, free up MOD pin
    M950 S0 C"zprobe.mod" ; servo/gpio 0 is Z probe MOD pin
    ...
    M280 P0 S10 ; send control signal to BLTouch through servo/gpio 0"

    With no disrespect... The lines in the GCode manual need changing as M950 needs to be before the 558..

    So I dropped in the M950 command first, then the M558 command as in the manual.
    Then ran the M280 command and the pin fired. Brill

    Ran the individual axis homing X, Y and then Z.
    I had my finger under the probe and it hit and the moved back up.

    Do I need to use the ' ^ ' on the M950 command or leave it without?

    Regards,

    Paul



  • @PaulHew said in Maestro, RRF3 and BLTouch issues:

    With no disrespect... The lines in the GCode manual need changing as M950 needs to be before the 558..

    the configurator creates M950 before M558 for me.

    the ^ is the command for the pull up register. if it works fine for you without it then you dont need it.


  • administrators

    @PaulHew said in Maestro, RRF3 and BLTouch issues:

    M558 P9 C"zprobe.in" H5 F120 T3000 ; BLTouch connected to Z probe IN pin, free up MOD pin
    M950 S0 C"zprobe.mod" ; servo/gpio 0 is Z probe MOD pin

    The correct code is as shown, except that for new BLTouch you need to enable the pullup resistor:

    M558 P9 C"^zprobe.in" H5 F120 T3000 ; BLTouch connected to Z probe IN pin, free up MOD pin
    M950 S0 C"zprobe.mod" ; servo/gpio 0 is Z probe MOD pin

    If you swap the M950 and M558, that won't work using RRF 3.0 stable (because the Z probed owns the zprobe.mod pin by default in that version), but it will work in 3.01beta.

    Use M401 and M402 to test BLTouch deployment and retraction.



  • This is getting frustrating!

    More info. I put the following lines into a new macro, I copied them directly from the config.g

    M950 S0 C"^zprobe.mod" ; create servo pin 0 for BLTouch
    M558 P9 C"zprobe.in" H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds

    Powered off the Maestro and back on again, 1) to reset the pin back to its normal position and 2) To make sure it fires on startup.

    Waited 30 secs. Sent the M280 P0 S10 command and the pin does not fire.

    Ran macro with the 950 and 558 commands above, then the M280 P0 S10 and the pin fires.

    It seemed like it was not reading the config.g properly, so I took the original SD Card which came with the Duet, Format and copied all my new stuff over.
    Same issue until I run the macro the probe does not deploy.

    Final Test, reboot, pin is in. Run individual homing, Z does not deploy pin.
    Reboot again.
    Run macro, run individual homing and the pin deploys when it prepares to home Z.

    Also created a new config.g but no difference, still have to run the macro before homing.

    I have included my Sys directory and the macro.[0_1579277936333_PMFH Sys folder.zip](Uploading 100%)
    Hope someone can shine some light.
    retractprobe.g homez.g homey.g homex.g homeall.g deployprobe.g config-override.g config.g bed.g [0_1579278013302_RRF3 Probe](Uploading 100%) RRF3 Probe.txt

    Kind Regards,

    Paul



  • @PaulHew said in Maestro, RRF3 and BLTouch issues:

    M950 S0 C"^zprobe.mod" ; create servo pin 0 for BLTouch

    M558 P9 C"zprobe.in" H5 F120 T3000 ; BLTouch connected to Z probe IN pin, free up MOD pin
    M950 S0 C"zprobe.mod" ; servo/gpio 0 is Z probe MOD pin

    That should be the right code.



  • @DIY-O-Sphere
    The content of files is looking good. Exept the misassign of the probe in config.g



  • @DIY-O-Sphere You are right, Just swapped the lines round in my config.g and it worked.

    That came out of the config tool that way round.

    Thank you. I thought I was going mad.

    Makes sense now when I run my macro, 558 effectively was the last command so when 950 runs from my macro it sorts it out.

    Thank you again.

    @dc42 and @Veti
    Apologies guys, that is why I thought the GCode wiki was wrong, as that how it came out of the config tool.

    Paul.



  • @PaulHew said in Maestro, RRF3 and BLTouch issues:

    That came out of the config tool that way round.

    You have first to unassign zprobe.mod from the modulation pin.
    Only then you can assign zprobe.mod to the PWM control.

    94e00844-1366-4e4f-b5f4-47e3e6bdb027-grafik.png

    Else the Bltouch is not selectable in the endstop tab.

    53848463-7e4a-41fb-90e8-1638f046ea7f-grafik.png

    That generates a proper configuration.


Log in to reply