Problem with Extruder Force - Config-Problem



  • Hi,
    I've set up my first Duet 2 Wifi printer. Up to now all works flawless - but now I had an issue I couldnt't solve anymore with google/forum search...

    First: I'm not sure if I've choosen the right category - so please move it, if it the wrong one 🙂

    Problem:
    The Extruder-stepper has no force. My first thought was that the current settings are to low and increased it a bit - but with the same result: no force.

    Then I just plug the extruder stepper on the x-driver, moved x and it has got full power.

    Then I configured the x-drive to be the extruder drive and it results again with less force as in the beginning. If I configure E1 I've no force too.

    So I can assume that it is no defect at the extruder stepper itselft.
    I think that it MUST be then a configuration problem, if a port is configured as Extruder...?

    To test the extruder stepper, I just set M302 S25 R25 and heated to 25 degrees to move the extruder.

    I also have tested two different steppers (LDO 1.8 Pancake and an LDO 0.9 Pancake).
    Both have full power when not connected to an as extruder declared port....

    Thank you for help!

    Tom

    Her is my config.g:
    (actual running firmware: 2.05)

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.5 on Sat Jan 11 2020 16:48:43 GMT+0100 (Mitteleuropäische Normalzeit)
    
    ; General preferences
    G90                                              ; send absolute coordinates...
    M83                                              ; ...but relative extruder moves
    M550 P"Mjollnir"                               ; set printer name
    
    ; Network
    M552 S1                                          ; enable network
    M586 P0 S1                                       ; enable HTTP
    M586 P1 S1                                       ; enable FTP
    M586 P2 S0                                       ; disable Telnet
    
    ; Drives
    M569 P0 S0                                       ; physical drive 0 goes backwards - x-axis
    M569 P1 S0                                       ; physical drive 1 goes backwards - y-axis
    M569 P2 S0                                       ; physical drive 2 goes backwards - z-axis left
    M569 P3 S1                                       ; physical drive 3 goes forwards  - Extruder
    M569 P4 S0                                       ; physical drive 4 goes backwards - z-axis right!
    M584 X0 Y1 Z2:4 E3                               ; set drive mapping: two Z motors connected to driver outputs Z and E1
    M671 X-41:289 Y0:0 S0.5 		                 ; leadscrews at left (connected to Z) and right (connected to E1) of X axis
    M350 X16 Y16 Z16 E16:16 I1                       ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E830.00:400.00       ; set steps per mm
    M566 X600.00 Y600.00 Z12.00 E300.00:12.00        ; set maximum instantaneous speed changes (mm/min)
    M203 X12000.00 Y12000.00 Z600.00 E1500.00:600.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z200.00 E2100.00:200.00   ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800:800 I30                 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                          ; Set idle timeout
    
    ; Axis Limits
    M208 X-1 Y-7.5 Z0 S1                                ; set axis minima
    M208 X254 Y212 Z318 S0                         	    ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 S3                                    ; set endstops controlled by motor stall detection
    M574 Z1 S2                                       ; set endstops controlled by probe
    ;M591 D0 P2 C3 S1                                ; Filament Sensor an E0, Endstop 3, Mode P1 Signal low wenn Filament da, S1: Pause on error
    ;Filament actual is disabled
    
    ; Stallgaurd Sensitivy
    M915 X S1 F0 H200 R0		        			 ; Set X axis Sensitivity
    M915 Y S1 F0 H200 R0		          			 ; Set y axis Sensitivity
    
    ; Z-Probe
    M307 H3 A-1 C-1 D-1                              ; disable heater3 on PWM channel for BLTouch. Hier auf Heater 3 wird BL-Touch angeschlossen - Pin-Out 8!!
    M558 P9 H5 F360 A3 T9000                         ; set Z probe type to bltouch and the dive height + speeds
    G31 P25 X-23.5 Y-36.0 Z2.410                     ; set Z probe trigger value, offset x=-36.0, y=-23.5 and trigger height 0!!
    M557 X5:230 Y5:175 P5:5                          ; define mesh grid - grob 5x5=25, mittel 7x7=49; fein 10x10=100, extra fein: 15x15=225 Hyperfein=20x20=400
    
    ; Heaters
    M307 H0 B0 S1.00                                 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700                      ; set thermistor + ADC parameters for heater 0
    M143 H0 S120                                     ; set temperature limit for heater 0 to 120C
    M305 P1 T500000 B4723 C1.196220e-7 R4700         ; set thermistor + ADC parameters for heater 1
    M143 H1 S280                                     ; set temperature limit for heater 1 to 280C
    M305 P100 S"MCU"								 ; set virtual heater for the MCU
    M305 P101 S"Drivers"							 ; set virtual heater for stepper drivers
    
    ; Fans
    M106 P0 S1 I0 F500 H1 T45                        ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S0 I0 F500 H-1                           ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    
    ; Tools
    M563 P0 D0 H1 F0                                 ; define tool 0
    G10 P0 X0 Y0 Z0                                  ; set tool 0 axis offsets
    G10 P0 R0 S0                                     ; set initial tool 0 active and standby temperatures to 0C
    M302 S10 R10
    
    
    
    


    1. As your Z have 2 drivers and E only one, config should looks like this:
      M584 X0 Y1 Z2:4 E3 (as it is)
      M671 .....as it is
      M350 X16 Y16 Z16:16 E16 I1
      M92 X100 Y100 Z400:400 E830
      M566 X600 Y600 Z12:12 E300
      M203 X12000 Y12000 Z600:600 E1500
      M201 X1000 Y1000 Z200:200 E2100
      M906 X800 Y800 Z800:800 E800 I30

    2. You need to heat up your hotend to extrude or allow cold extrusion (without filament of course).



  • @aidar
    THANK YOU!!!!
    You are my HERO of the day!
    I don't know how often I go through the config - but the hell I haven't seen this failure!
    Now it works!



  • @dc42
    You need to correct this wiki - Step3 - this was it I used to config mine...

    https://duet3d.dozuki.com/Guide/Independent+Z+motors+and+endstop+switches/18


  • administrators

    @aidar said in Problem with Extruder Force - Config-Problem:

    M350 X16 Y16 Z16:16 E16 I1
    M92 X100 Y100 Z400:400 E830
    M566 X600 Y600 Z12:12 E300
    M203 X12000 Y12000 Z600:600 E1500
    M201 X1000 Y1000 Z200:200 E2100
    M906 X800 Y800 Z800:800 E800 I30

    Those changes are not necessary. It's only the E parameters of these commands that support multiple values - because you can have multiple extruders (perhaps of different types) that can work independently, but only one X axis, one Y axis etc.



  • @dc42
    but those changes solved the problem.

    Or do you mean that I only need it this (even for the independ z-config with the seccond one on E1)?

    M584 X0 Y1 Z2:4 E3
    M350 X16 Y16 Z16 E16 I1
    M92 X100 Y100 Z400 E830
    M566 X600 Y600 Z12 E300
    M203 X12000 Y12000 Z600 E1500
    M201 X1000 Y1000 Z200 E2100
    M906 X800 Y800 Z800 E800 I30



  • @dc42
    ok - I found it in the gcode description 🙂
    (I should have had an eye on earlier...)



  • @tom_Nbg Yes. Your original configuration had values for multiple extruders separated by colons but you have only defined a single extruder in your M584. Steps per mm, accelerations, jerk, speed and motor current only need single values for X,Y Z and E.


Log in to reply