smart effector sensibility issue



  • I have 2 smarteffectors.
    One of them has issues with sensibility just right after I power on the printer.

    It´s way too sensitive, and it triggers the probe just by turning on fans manually, or the slightest move like homing.

    I have to set a macro so I pause for 4 seconds, reset to default wait for 4 secs, set sensitibilty to 75:180, and wait 2 more seconds.

    That way it works fine, but next day I turn the machine on, it´s wrong again and have to run again the macro.

    So I´ve decided to run the macro at the at the very end of the config file (after m501), and most of the times it runs ok. Some times I have to do a hard power down, and up so it set the sensitibity ok.

    The other smarteffector just runs OK at stock default sensitibity.

    Is there something that I am missing? I´s driving me nuts.


  • administrators

    I think that effector needs to be re-programmed, because it should remember its settings. Please ask your supplier to re-program or replace it.



  • @dc42 said in smart effector sensibility issue:

    I think that effector needs to be re-programmed,

    I have to ask 😄 .. was just looking at the pcb and schematic design and hm .. must ask .. what's the resistance delta of this track while bending? I was using pcb for so many things but reading bend of the pcb never crossed my mind 😄 .. I assumed smart effector had some piezo element built in but when you mentioned "programming" I had to go look at it 🙂


  • administrators

    The resistance delta is tiny, so the signal generated is only a few tens of microvolts. That's why a fan that is too close to the amplifier circuit can induce enough signal to cause it to trigger.

    However, if both your effectors use the same types of fans and are assembled similarly, they should behave in the same way.



  • back-of-a-napkin type of calculation might suggest 50uV would equate to 0.3ohm (on each arm of the half bridge) or 0.015mV/V. curious if a piezo resitive element would help, the gain factor is several orders of magnitude larger but it also comes with noise.



  • the mag arms are set to oposite polarity to compensate, and the effectors are set up just alike, the only difference is that one is v6 and the other one is volcano...

    I´ll ask hector to talk to you guys, as I think he buys directly from you.



  • @dc42 said in smart effector sensibility issue:

    I think that effector needs to be re-programmed, because it should remember its settings. Please ask your supplier to re-program or replace it.

    If I send M672 S65:65 it will erase the eprom, and I could check if the issue remains, or I might brick the smarteffector?

    but it seams this unit is affected by this issue
    https://github.com/dc42/Duet3dSmartEffector/releases


  • administrators

    @apak said in smart effector sensibility issue:

    @dc42 said in smart effector sensibility issue:

    I think that effector needs to be re-programmed, because it should remember its settings. Please ask your supplier to re-program or replace it.

    If I send M672 S65:65 it will erase the eprom, and I could check if the issue remains, or I might brick the smarteffector?

    but it seams this unit is affected by this issue
    https://github.com/dc42/Duet3dSmartEffector/releases

    I agree, it is affected by that issue, so the firmware needs to be updated because you need the facility to change the sensitivity. Which country are you in?



  • Spain...my provider Hector, has contacted his sales rep...so let´s wait for it.


Log in to reply