Yet another BL touch not deploying



  • Hi,

    Pulling my hair out on installing this (i know, its a clone) BL Touch clone.

    Everything is working fine, probe does a self test (goes up/down 2 times)

    • M280 P3 S10 I1 deploys the pin (at console)
    • M280 P3 S90 I1 retracts the pin (at console)
    • M280 P3 S120 does a test (pin goes up/down continuous)
    • M280 P3 S160 resets the probe (led stops flashing and becomes a solid red)

    -----------------------------------------------------
    some file infos:

    #config.g

    ; Z endstop

    M574 Z1 S2

    ; Z-Probe

    M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M558 P9 H3 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X43 Y8 Z1.5 ; set Z probe trigger value, offset and trigger height
    M557 X43:282 Y8:322 S20 ; define mesh grid

    #deployprobe.g

    M280 P3 S10 I1

    #retractprobe.g

    M280 P3 S90 I1

    -----------------------------------------------------

    If I add the deploy probe code into my homez.g file, it works, probe goes to first point and pin deployed (manually be the code, not automatically like it should) and bed is level.

    I ran through all the troubleshooting pages and tests for leveling.

    here is the problem.

    M401 & M402 does not work.

    When doing a G29 , it goes to the first point and starts raising my bed (core XY printer) but probe is not deployed so nozzle crashes into the bed.

    What could I be doing wrong ? probe pin should deploy & retract as per the M558 P9 setup.

    Thank you for any tips.

    J-F


  • Moderator

    What firmware version are you running? What version of BLTouch clone is it?

    It's very strange that M280 P3 S10 I1 from the console works to deploy the pin, but M401 does not.

    What happens if you right click on deployprobe.g macro and run it?

    I would suggest recreating the deployprobe.g and retractprobe.g macros from scratch.

    Just as an aside, change G31 P500 to G31 P25



  • thanks for replying.
    Firmware is the latest in the 2.x branch.

    Board: Duet WiFi 1.02 or later
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.05.1 (2020-02-09b1)
    Duet WiFi Server Version: 1.23
    

    As the probe goes, its a "Smart 3D touch" I dont know the version but its brand new.

    as for the 2 gcode files, i've even tried to change the names with first uppercase letter as seen in a couple of places. (should not be, all other files are in lower case but tried it anyway)

    btw: there is nothing in the config-override.g (forgot to mention in my original post)

    Is it normal that the "run command" is not in the right click menu (in the system folder) ? only:

    • download file
    • edit file
    • rename
    • delete

    are available

    Thanks.



  • ok, So redid the (deploy|retract)probe.g files and looks like everything is working fine.

    Thanks @Phaedrux for the hint..

    This can be marked as solved.


  • Moderator

    Glad it worked out. Did you get the original files from the web configurator, or had you created them yourself?


Log in to reply