Clicking and retracting issue



  • Hi,

    I have seen two other posts on this but didn't really help me.

    I am having bad clicking noises (only managed to film one click), and retracting issues.

    https://drive.google.com/open?id=1dd1H-252rOCX8ahfpOWwq9hGJ9HM0DOy

    It is also stripping my filament. The prints are unaffected... at the same time if you have any suggestions regarding my config I will be happy to hear.

    I am running an Ender 3 with Duet Wifi.

    Here is my config:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Sep 06 2018 21:21:12 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name
    M918 P1 E4 F2000000 ; configure direct-connect display

    ; Network
    M550 Pe3 ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X256 Y256 Z16 E16 I0 ; configure microstepping with interpolation
    M92 X1280.00 Y1280.00 Z400.00 E410 ; set steps per mm
    M566 X600.00 Y600.00 Z60.00 E300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z6000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X200.00 Y200.00 Z100.00 E250.00 ; set accelerations (mm/s^2)
    M906 X700 Y700 Z760 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X235 Y235 Z260 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M307 H4 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H9 F120 R0.2 T18000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X-31 Y0 Z2.212 ; Set Z probe trigger value, offset and trigger height
    M557 X50:200 Y50:200 S65 P3:3 ; Define mesh grid

    ; probe locoation
    M557 P1 X41 Y25
    M557 P2 X120 Y25
    M557 P3 X200 Y25
    M557 P4 X200 Y135
    M557 P5 X120 Y135
    M557 P6 X41 Y135
    M557 P7 X41 Y200
    M557 P8 X120 Y200
    M557 P9 X200 Y200

    ; Heaters
    M305 P0 T98801 B4185 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    ;M305 P1 X150 T"K" ; Set THERMOCOUPLE parameters for heater 1 X150 is the right channel (terminal block) on the daughterboard. X151 is the right channel.
    M305 P1 T98801 B4185 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S345 ; Set temperature limit for heater 1 to 345C

    ; Fans
    M106 P0 S0 I0 B0.5 F250 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 B0.5 F500 L255 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Minimum Speed is 1/3 aka 87 Thermostatic control is turned on triggered at nozzle temp 45;
    M106 P2 S0 I0 B0.5 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings
    M918 P1 E4 ; Enable 12864 LCD with 1 menu item per encoder click
    M563 P0 D0 H1 F2
    ;M591 D0 P5 C3 R10:300 E3.0 S1 ; Duet3D laser sensor for extruder drive 0 is connected to endstop input 3 (E0), tolerance 10 to 120%, 3mm comparison length



  • M92 X1280.00 Y1280.00 Z400.00 E410 ; set steps per mm
    M566 X600.00 Y600.00 Z60.00 E300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z6000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X200.00 Y200.00 Z100.00 E250.00 ; set accelerations (mm/s^2)
    M906 X700 Y700 Z760 E800 I30 ; set motor currents (mA) and motor idle factor in per cent

    I'm wondering about the 410 steps/mm for an Ender 3... mine runs at 99-101, but I'm on an Ender 3 Pro with the plastic extruder. All the same it seems a LOT bigger feed rate.

    Have you calibrated your extruder esteps? If not almost certainly that.

    Some of your stepper motor currents seem a little odd too (to me, I could be wrong). I wonder about XYZ currents being lower than the extruder current. I don't think it's got anything to do with your skipping problem, but it doesn't seem to be right.

    Mind you, when I have a look at mine, the extruder motor is much larger than the others, so it could be correct.

    I'm tipping feed rate.


  • Moderator

    Definitely skipping extruder.

    It would seem your thermistor values are correct providing you're using the stock thermistor from creality.

    If you haven't calibrated the extruder yet, starting with PID tuning the heater, see here: https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+4:+Calibration/40#s161

    It really seems like printing faster than the volumetric rate will allow. There's even a video in that link with a skipping extruder that looks very similar.

    M350 X256 Y256 Z16 E16 I0 ; configure microstepping with interpolation

    Your microstepping values for X and Y are pretty overkill, and your other axis are missing out on x256 interpolation. I would suggest sticking to x16 with interpolation enabled. Things will move smoother for all axis and be quieter.

    After the skipping is occuring, if you run a M122, do you see a hiccup count?

    Are your motor currents set to 70-85% of their rated max?



  • @Phaedrux Thanks. When you said this: "Your microstepping values for X and Y are pretty overkill, and your other axis is missing out on x256 interpolation. I would suggest sticking to x16 with interpolation enabled. Things will move smoother for all axis and be quieter."

    What and where do you mean? Can you point me to what line in the config is overkill and how I would add x256 inerpolation?
    Thanks



  • @Phaedrux When changing M350 to x16 it goes crazy fast and crashes in the sides.


  • Moderator

    @Elliot said in Clicking and retracting issue:

    M350 X256 Y256 Z16 E16 I0 ; configure microstepping with interpolation
    M92 X1280.00 Y1280.00 Z400.00 E410 ; set steps per mm

    When you change the M350 to x16 you'll need to recalculate your steps per mm for the M92. That's why it's going faster and thinking it hasn't moved as much.

    If you device 1280 by 16, you get 80. So try

    M92 X80 Y80 Z400.00 E410
    M350 X16 Y16 Z16 E16 I1
    


  • @Phaedrux Thank you so much! I also changed my E410 to E97 after doing the calibration tests.
    I did see this line in one of the default config files:

    M350 X32 Y32 E128 I1 ; Set steps per mm for the extruder to x128 (776 steps per mm) and X and Y to x32 (160 steps per mm)

    What does this do and is it needed?


  • Moderator

    Are you referring to this guide? https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+2:+Configuration/38#s128

    If you're using the stock ender extruder, 97 would be the default steps per mm. The reasoning behind increasing the microstepping is to gain greater accuracy from the extruder.

    That guide also uses the Duet Maestro which allows the use of interpolation to x256 from any starting microstepping level. The Duet Wifi only supports interpolation to x256 when using x16 microstepping.

    So in your case, I would leave it at x16 microstepping all around, and enable interpolation so that the drivers can send x256 pulses to the motors.


Log in to reply