CR10v2 - Duet 3 Connections



  • I went through the rep rap configuration utility as best I could for my CR10v2 - Duet 3 combo. I have included here text of the config.g file and an image showing the things I have wired up already. The things I have left are the X and Y Endstops and the BLTouch. I just want to ensure that I have these last things plugged in correctly based on the config.g file.

    Thanks for the help!

    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Tue Mar 17 2020 20:22:10 GMT-0500 (Central Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Duet 3" ; set printer name

    ; Drives
    M569 P0.0 S1 ; physical drive 0.0 goes forwards
    M569 P0.1 S1 ; physical drive 0.1 goes forwards
    M569 P0.2 S1 ; physical drive 0.2 goes forwards
    M569 P0.3 S1 ; physical drive 0.3 goes forwards
    M584 X0 Y1 Z2:3 E4 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X300 Y300 Z400 S0 ; set axis maxima

    ; Endstops
    ;M574 Z1 S2 ; configure Z-probe endstop for low end on Z
    ; Endstops
    M574 X1 S1 P"xstop"
    M574 Y2 S1 P"!ystop"
    M574 Z1 S2
    M574 U2 S1 P"^duex.e2stop"

    ; Z-Probe
    M950 S0 C"io4.out" ; create servo pin 0 for BLTouch
    M558 P9 C"io7.in+io7.out" H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"temp0" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin temp0
    M950 H0 C"out0" T0 ; create bed heater output on out0 and map it to sensor 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"temp1" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin temp1
    M950 H1 C"out1" T1 ; create nozzle heater output on out1 and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"out3" Q500 ; create fan 0 on pin out3 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"out4" Q500 ; create fan 1 on pin out4 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    0b0830ee-973f-4793-a378-b644b2edb1a4-image.png



  • Motor and thermistor config seems to match the inputs and outputs as marked yes.



  • So I guess I'm just confused where these last guys get plugged in. I'm having a hard time finding where on the board I find these:
    ; Endstops
    M574 X1 S1 P"xstop"
    M574 Y2 S1 P"!ystop"
    M574 Z1 S2
    M574 U2 S1 P"^duex.e2stop"

    Same thing for the for the BLTouch
    ; Z-Probe
    M950 S0 C"io4.out" ; create servo pin 0 for BLTouch
    M558 P9 C"io7.in+io7.out" H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds

    The BLTouch has one plug with three wires and one with two wires.

    Hopefully this makes sense!

    Pat



  • I was wondering about that bit, my understanding is that you would have used IO_1.in instead of xstop but not my area of expertice.

    Did you use the online configurator? Just tried it and it proivded a different, and probably correct output to me?

    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Fri Mar 20 2020 03:16:49 GMT+0100 (Central European Standard Time)
    
    ;...<snip>...
    
    ; Endstops
    M574 X1 S0 P"io1.in"                         ; configure active-low endstop for low end on X via pin io1.in
    M574 Y1 S0 P"io2.in"                         ; configure active-low endstop for low end on Y via pin io2.in
    M574 Z1 S2                                   ; configure Z-probe endstop for low end on Z
    

    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_Duet_Num_3 lists the connections for the BLTouch and the accompanying config from the configuration tool should work

    ; Z-Probe
    M950 S0 C"io7.out"                           ; create servo pin 0 for BLTouch
    M558 P9 C"io7.in" H5 F120 T6000              ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z2.5                          ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20                     ; define mesh grid
    


  • @BearcatTD see edit ☝



  • Thanks! Yes, I used the config utility online to get the above config.g file. I'll edit the file with your suggestions and give it a go!!



  • @BearcatTD said in CR10v2 - Duet 3 Connections:

    Yes, I used the config utility online to get the above config.g file

    could you upload the config.json file it procuced? I would think devs would want to look at that if thats the output you got.



  • Will do!

    config.json



  • that is very strange, only issue I could see is the bltouch was split betwwen io4 and io7 , endstops should have come out as io1 and io2, smells like a bug.



  • I'm glad to help...LOL!



  • haha, you can laugh but if it saves someone else from banging their head against the wall its well worth it! 👍



  • Amen to that. Usually I'm the one doing the head banging. And not in an awesome 80' Rock way.



  • @bearer said in CR10v2 - Duet 3 Connections:

    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_Duet_Num_3

    So here is the BLTouch Duet 3 hookup

    I get the impression that the ground pin will have two wires?
    Screen Shot 2020-03-20 at 11.18.02 AM.png

    I get the impression that the ground pin will have two wires?



  • Dealers choice. They're connected internally in the BLTouch and won't carry much current, so 1 or 2 will be fine when all connectors go to the same header imo. (but i suspect there are two grounds to insure signal integretry for RAMPS boards where the signal and pwm are split to different headers)

    But yeah, I'd join them, its tidyer and you don't have one lead flapping about.


Log in to reply