Duet2 Wifi goes crazy when printing second print after first one



  • Greetings,

    havent used my cartesian-style DIY printer for a while so I have clue if I have changed something at some point.

    However, first print goes good, no problems. Then if I start a second print right after another, the printer does weird things:
    Z-height doesnt seem to move
    X goes to maximum (200)
    Y goes slowly to maximum (290)
    Then extruder starts pumping filament into extruder at very rapid speed and obiviously starts grinding the filament, at this point i just turn off the machine. Any idea why this is happening? I remember printing multiple files consecutively previously. I also dont have homing sequence in the beginning of each print since I prefer doing it manually, I also have sensorless homing which is not 100% accurate (differs like 0.5mm) and I like to fine tune with babystepping.

    Below are my config and homing files, and here are my Cura before/after print files:

    G29 S1 ; load heightmap from file
    ;Prime the extruder
    G92 E0
    G1 F200 E3
    G92 E0
    
    M104 S0
    M140 S0
    ;Retract the filament
    G92 E1
    G1 E-1 F300
    M106
    G91
    G1 Z50 F5000
    

    homeall.g config.g


  • Moderator

    Can you post the first 50 lines or so of your sliced gcode file?

    You're using stall detection on Z?

    Do you have Cura set to use relative extrusion?


  • Moderator

    @gm need to see your config.g. I’d expect either your Endstops or M208 (bed size) settings are incorrect. Post whole Gcode file, too, as something at the end may be causing this. Finally, send M115 to printer and post response for firmware version.

    Edit: sorry I see you posted config.g and end Gcode already. But on phone, so can’t read it!

    Ian



  • @Phaedrux said in Duet2 Wifi goes crazy when printing second print after first one:

    Can you post the first 50 lines or so of your sliced gcode file?

    You're using stall detection on Z?

    Do you have Cura set to use relative extrusion?

    Here you go!

    First time printing this, no problem. After finishing and printing the exact same file without restart/emergency stop inbetween it will freak out
    flowRateCalibrationCube_0.8mmWalls.gcode

    Im using stall detection on all axis for homing. Z homes to maximum value (nozzle in the air). Usually need like 0.10-0.15 babystepping to get good first layer.

    Cura is set to relative extrusion (seems to be default).

    Thanks


  • administrators

    I think part of the problem is this near the end of your GCode file, which I presume is from your end GCode script:

    G91
    G1 Z50 F5000
    M83 ;relative extrusion mode
    M104 S0
    ;End of Gcode
    

    You set relative movement mode using G91 before the Z move, but you never set it back to absolute using G90. So the printer is in relative movement mode for that input channel when you start the next print.


  • Moderator

    Add a G90 to your start script.


Log in to reply