Z probing offset



  • Hi everyboy,

    It' seems that the G29 command does'nt care about the X and Y offset I setted with the command G31.

    The probing process move the nozzle at the coordinate instead of the prob.

    Here is a part of my config.g:

    ; Z-Probe
    M307 H3 A-1 C-1 D-1                            ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F100 T6000                          ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y79.3 Z1.72                        ; Set Z probe trigger value, offset and trigger height
    M557 X20:280 Y20:280 S20                       ; Define mesh grid
    

    Ana here is my Bed.g:

    M561 ; clear any bed transform
    G29  ; probe the bed and enable compensation
    

    My bed is 300 * 300 and every point over Y 220 is not probed.

    Anynody can help ?

    Bye
    Juan



  • You have defined a y offset of 79.3 mm. The probe can't physically reach 300 mm.
    With the offset being positive, I would expect the probing to start at y=100 (offset of 80 and 20 offset as per your probing setup on M557) but I am not certain here.



  • Your mesh grid is defined as up to 280. Now, when Y220 work fine, your next probing point on Y axis are 220 + 20 (S parameter in M557) + 79.3 (probe offset) = 319.3 . So your probe just cant reach that, your bed is 300.
    If it can, i mean if it is over bed when you are at Y300, then your probe offset is with wrong sign.



  • To more clear,

    when the nozzle is at 300 the prob is at 379.3 that is outside of the print area.

    Now for example : when I prob 150:150, i'm expect the prob at 150:150 and the nozzle at 150:70.7



  • Shouldn't that read "when I probe at 150:150 the nozzle will be at 150:229.3" ?



  • @jens55 said in Z probing offset:

    Shouldn't that read "when I probe at 150:150 the nozzle will be at 150:229.3" ?

    Nop,

    I juste trie to put -79.3 to the y offset and it "compensate" twice the offset.

    I'am doing something wrong but can't find what is it...



  • Please post your config.g file



  • @aidar Ok here is my entire config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Wed Jul 10 2019 22:12:37 GMT+0200 (heure d’été d’Europe centrale)
    
    ; General preferences
    G90                                            ; Send absolute coordinates...
    M83                                            ; ...but relative extruder moves
    
    M669 K1                                        ; Select CoreXY mode
    
    ; Network
    M550 P"Hyper Cube La Muerte"                   ; Set machine name
    M552 S1                                        ; Enable network
    M587 S"HUIT-FILLES" P"Muahahaha" ; Configure access point. You can delete this line once connected
    M586 P0 S1                                     ; Enable HTTP
    M586 P1 S0                                     ; Disable FTP
    M586 P2 S0                                     ; Disable Telnet
    
    ; Drives
    M569 P0 S0                                     ; Physical drive 0 goes forwards
    M569 P1 S0                                     ; Physical drive 1 goes forwards
    M569 P2 S0				       ; Physical drive 2 goes forwards
    M569 P3 S0                                     ; Physical drive 3 goes forwards
    M350 X256 Y256 Z256 E256 I0                    ; Configure microstepping without interpolation
    M92 X1280.00 Y1280.00 Z6400.00 E13395.20      ; Set steps per mm
    ;M566 X900.00 Y900.00 Z12.00 E120.00            ; Set maximum instantaneous speed changes (mm/min)
    M566 X1000.00 Y1000.00 Z50.00 E120.00            ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z500.00 E3000.00        ; Set maximum speeds (mm/min)
    ;M201 X750.00 Y750.00 Z20.00 E250.00            ; Set accelerations (mm/s^2)
    M201 X1000.00 Y1000.00 Z100.00 E250.00            ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z1200.00 E800.00 I30       ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                        ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                               ; Set axis minima
    M208 X300 Y300 Z300 S0                         ; Set axis maxima
    
    ; Endstops
    M574 X1 Y1 S3                               ; Set endstops controlled by motor load detection
    M574 Z1 S2
    M915 X Y S7 R1
    
    ; Z-Probe
    M307 H3 A-1 C-1 D-1                            ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F100 T6000                          ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y79.3 Z1.28;Z1.72                        ; Set Z probe trigger value, offset and trigger height
    M557 X20:280 Y20:280 S20                       ; Define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                               ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B3950 R4700                    ; Set thermistor + ADC parameters for heater 0
    M143 H0 S150                                   ; Set temperature limit for heater 0 to 150C
    
    M305 P1 T100000 B4725 C7.060000e-8             ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280                                   ; Set temperature limit for heater 1 to 280C
    
    ; Fans
    ;M106 P0 S0 I0 F500 H T45                       ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ;M106 P1 S1 I0 F500 H1 T45                      ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S0 I0 F500 H-1
    M106 P2 T45:65 H100:101:102
    
    ; Tools
    M563 P0 D0 H1 F1                                  ; Define tool 0
    G10 P0 X0 Y0 Z0                                ; Set tool 0 axis offsets
    G10 P0 R0 S0                                   ; Set initial tool 0 active and standby temperatures to 0C
    M572 D0 S0.25 ;S0.15
    
    ; Automatic saving after power loss is not enabled
    
    ; Custom settings are not configured
    
    ; Miscellaneous
    M501                                           ; Load saved parameters from non-volatile memory
    
    
    


  • Just in case
    21a90b72-7a88-496f-a32c-4fef514784f3-image.png



  • Something is wrong with your coordinate system. If you probe offset is really Y almost 80, then you should be able to probe Y up to 300 easy, however you can not probe Y less then 80.
    In your case you have opposite problem, so either your probe offset is with wrong sign, or your Y + and - are swapped.

    I also reccomend to update firmware to latest 2 series, it is 2.05.1



  • 100 % okay with min 80 and max 300 for the prob area ( at least I anderstand right )

    It seams now it works fine again.
    It like when I changed the config.g to test oposit sign, it reseted something.
    Now it works well with my original +79.3

    can the M501 at the end cause this behaviour ?



  • Depends what you have in your config-override.g file



  • only the pwm configuration

    ; config-override.g file generated in response to M500 at 2019-07-13 14:44
    ; This is a system-generated file - do not edit
    ; Heater model parameters
    M307 H0 A155.6 C454.0 D3.3 S1.00 V25.6 B0
    M307 H1 A523.8 C225.8 D3.4 S1.00 V25.5 B0
    M307 H2 A434.6 C193.2 D3.9 S1.00 V23.4 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    G10 L2 P1 X0.00 Y0.00 Z0.00
    G10 L2 P2 X0.00 Y0.00 Z0.00
    G10 L2 P3 X0.00 Y0.00 Z0.00
    G10 L2 P4 X0.00 Y0.00 Z0.00
    G10 L2 P5 X0.00 Y0.00 Z0.00
    G10 L2 P6 X0.00 Y0.00 Z0.00
    G10 L2 P7 X0.00 Y0.00 Z0.00
    G10 L2 P8 X0.00 Y0.00 Z0.00
    G10 L2 P9 X0.00 Y0.00 Z0.00
    


  • Looks ok, however i would delete all unused commands from there, or even better put used M307 commands ( i see you have 3 of them) in config.g and not to use config-override at all.


Log in to reply