bontech bmg-x2 motors just buzz



  • I was wondering if you could help me I have been having some troubles getting the extruder motors to rotate. Any advice is appreciated.

    I have the wiring as follows
    Motor Board
    A+ to 2B
    A- to 2A
    B+ to 1A
    B- to 1B

    and my config.g is as follows

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Tue Mar 31 2020 12:15:10 GMT+0200 (Central European Summer Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M569 P4 S1 ; physical drive 4 goes forwards
    M584 X0 Y1 Z2 E3:4 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z800.00 E415.00:415.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00:120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z1200.00 E1200.00:1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z100.00 E250.00:250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z900 E1000:1000 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X350 Y335 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M558 P9 H5 F300 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-7.5 Y22.64 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:335 Y25:335 S40 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B3950 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T500000 B4723 C1.196220e-7 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S400 ; set temperature limit for heater 1 to 400C
    M305 P2 T500000 B4723 C1.196220e-7 R4700 ; set thermistor + ADC parameters for heater 2
    M143 H2 S400 ; set temperature limit for heater 2 to 400C

    ; Fans
    M106 P0 S0 I0 F20 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1:0 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H2:0 T45 ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Extruder 0" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"Extruder 1" D1 H2 F0 ; define tool 1
    G10 P1 X0 Y0 Z0 ; set tool 1 axis offsets
    G10 P1 R0 S0 ; set initial tool 1 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    T0 ; select first tool



  • Are the heaters hot, and/or have you enabled cold extrude?

    Also, you have a T0 in config.g, which is fine. Only that motor will move. (until you do a T1).

    And, have you checked wiring, per: https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors#Section_Identifying_the_stepper_motor_phases



  • In addition to what @Danal has said, the extruder motor currents look too high but it depends on the stepper motors you are using. If you are using ones supplied by Bondtech, then the maximum rated current is 700mA and you ought to run at about 85% of this so say 600mA and not 1000mA.



  • @Danal said in bontech bmg-x2 motors just buzz:

    Are the heaters hot, and/or have you enabled cold extrude?

    Also, you have a T0 in config.g, which is fine. Only that motor will move. (until you do a T1).

    And, have you checked wiring, per: https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors#Section_Identifying_the_stepper_motor_phases

    Yes I have the heaters warmed up.



  • Try and swap any two of the four leads in the wires. I usually swap the middle 2.
    Buzzing motors usually mean the coils are connected the wrong way



  • So it was a combination of to high amperage and the wiring. All is working the drawling that bondtech has on the site for the motor is in correct for the wiring. Used the link above and got it wires correctly. This bmg-x2-m prints awesome never had to cut extrusion down to 75% to keep from over extruding.


Log in to reply