Cannot connect to duet 085



  • Hi
    Have been looking thru the forum for a solution but nothing works (amongst others

    https://www.duet3d.com/forum/thread.php?id=909#p8900

    .
    All this trouble since I have a new pc.
    I have contact in S3D over usb

    and I can see the ip address, but cant connect to DWC over ethernet cable. Have flashed the board with the new firmware 1.18.1 and loaded dwc v1.15a on the sd-card. In the device manager it sees it as a USB serial device COM6. On the paneldue it states "connecting" all the time. Have switched cables, tried using another ethernet-switch but nothing works.
    Any help would be very much appreciated!
    Per



  • Plz anyone!!
    Have tried to reflash both paneldue & duet 085 (with firmware from Chrishamm Version 1.19-b4 for duet and Version 1.15c DWC on the sdcard and version 1.16.bin for paneldue) but still I can not get DWC to start (connection timed out) have tried again different cables but still no connection..
    Help!!



  • Have pinged from the cmd-prompt and when connected to internet it cant find it but when connected direct to the pc with ethernet the pinging worked . But still not being able to connect to DWC. Formatted the sd card and renewed the files, still no DWC!!!
    I am going crazy here, can someone help?



  • What browser are you attempting to use to connect?



  • I use Vivaldi, but have tried with Firefox and both Msn Edge and Msn Explorer

    And now also Chrome…. same same ERR_CONNECTION_TIMED_OUT

    ..... I have even tested it on a different pc... same result


  • administrators

    Are you sure there isn't already something else with that IP address on your LAN? It's usually safest to set the address to all zeros so as to use DHCP to assign an address, then run M552 to find out what address has been assigned.



  • Hi David and thanks for reply! Was away yesterday so no work then…
    But I am sorry to say that nothing of changing the ip address is working. If I set it to P0.0.0.0 for dhcp then I get "Network is enabled, configured IP address: 0.0.0.0, actual IP address: 0.0.0.0" and that dont work ofcourse.. If I change to something different (and I did not just try 192.168.1.14) I get "Network is enabled, configured IP address: 192.168.1.57, actual IP address: 192.168.1.57" and I get in any browser "ERR_CONNECTION_TIMED_OUT"
    What to do?? Are the board broken? That would be very strange because I havent done anything with it since the last print (just changed pc)
    Plz help!!


  • administrators

    With an IP address of all zeros, your router should assign it an IP address by DHCP. A direct connection to the PC won't work with an IP address of all zeros because the PC doesn't support DHCP.

    If you can get your router assigning it an IP address then the rest should work. I guess it's possible that your router has blacklisted the Duet's MAC address for some reason, so try a different one in your M540 command.



  • Ok, so to what should I change it to? My current mac address is M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED


  • administrators

    I suggest you change the last number from ED to something else e.g. 06. If that doesn't work, try changing the BE at the start to 7F or lower in case your router doesn't like locally-administered MAC addresses. You need to reboot the Duet for any change in MAC address to take effect.



  • David Youre an angel!!! Up and running DWC!! Yiipppeeee!! Thanks a billion!


  • administrators

    That was a lucky guess then!



  • Qualified, I´d say! 🙂


  • administrators

    Which number did you change, the ED or the BE?



  • The last digits ED, why?



  • Yesterday I had a problem similar to yours. USB Ok but unable to connect DWC. Until I rebooted my wifi rooter…



  • @Bravojul my issue is resolved thanks to David, but thanks for the hint, I did try that also. Its not my wifi router (never would have bought an apple router..) but somehow it blacklisted my MAC address. Now I have other problems not being able to home the printer…


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.