System 'freeze' at filament out



  • RRF3.05 (I think) and DWC 2.1.1 (I think)
    Was printing along and filament ran out. Printer behaved as expected but web control page presents this:

    Screenshot from 2020-04-12 13-56-15.png
    Yes, I could reset things but that would mean loosing the current print and I would rather not ...
    besides not having anything on the screen (except an empty text box), I see no way of carrying on after the filament is reloaded.

    SO, two things:
    How do I carry on printing now that the new filament is loaded (printer is waiting for some magic response but I have no clue what it would be, all key strokes I tried are being ignored)

    Ummm, there seems to be a bit of a bug .... 🙂


  • Moderator

    @jens55 Can you open a new browser tab and connect to DWC? I'm assuming you have some kind of filament sensor that triggered the pause.g, but what is it? What's in your pause.g? M291 message (RRF3 doesn't support blocking calls)?

    I can't remember what hardware this is on, Duet 2 Wifi?

    Ian



  • @droftarts , good show, opening another window got me the content of the text message

    Printing paused
    Extruder 0 reports no filament

    as well as the 'close' button. I was able to close the text box and carry on in the second browser window!
    Thanks for saving my partial print!

    The bug issue still remains 🙂

    It's a Duet2 wifi

    ; pause.g
    ; called when a print from SD card is paused
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Jul 06 2019 16:23:30 GMT-0700 (Pacific Daylight Time)
    M83 ; relative extruder moves
    G1 E-4 F3600 ; retract 4mm of filament
    G91 ; relative positioning
    G1 Z5 F360 ; lift Z by 5mm
    G90 ; absolute positioning
    G1 X0 Y0 F6000 ; go to X=0 Y=0



  • @droftarts said in System 'freeze' at filament out:
    <snip>

    M291 message (RRF3 doesn't support blocking calls)?
    <snip>

    Doesn’t seem to be anything to that effect in M291 documentation, however I did run into similar freezing issues when trying to use M291 from a macro and passing meta code as the P & R parameters.
    I put it down to malformed data allowing M291 to block, but not display a dialog.
    The same data invariably worked with an echo command, so I think it’s something to do with quoted string requirements


  • Moderator

    @OwenD it’s in the RRF3 notes: https://duet3d.dozuki.com/Wiki/RepRapFirmware_3_overview#Section_M291

    I don’t think it’s been fixed yet.

    Ian



  • I should add that this was never an issue before under RRF2. I don't know exactly when it got introduced.


Log in to reply