CoreXY layer shift but only in one direction



  • Hi everyone. I just finished my first corexy printer. Frame is a rat rig v-core V2. Board is a duet 2 wifi. Motors are wantai(?) or something like this, 1.7A 0.9 deegre. Frame is perfectly Square. Belts are equaly tensioned. Motors are a little warm. Board is cooled by 12x12 fan. All the cables are new. V slot wheels are super tight (loosing wheels a little doesn't help) . Gantry isn't shaking or anything.
    Print speed is 60mm/s. External perimeters 45mm/s. Tried acc from 1000 to 6000 and jerk from 300 to 900 no changes in layer shifting. Motors have 1.4A set from software. Stealth Mode isn't activated. Bed is on 4 Rails with V wheels and 3 lead screws on individual Motors.
    Bed Rails are clear and bed isnt shaking.

    And now the problem:
    When i print a xyz cube 20x20x20mm i got a single sometimes two layer shift only in "Y"(on cube from right to the left) direction but after this one particular layer everything Goes back to normal printing. Printed a little vase in vase Mode and spotted like 2 random spots where the "layers" are uneven on top of each other for something like 4mm?

    What can cause this issue?

    Edit #1 volume is around 500x500x500mm and extruder is a Titan aero with 837 steps and volcano block seems like perfect extrusion. Layer 0.3mm on 0.4mm volcano brass nozzle.


  • administrators

    Loose pulley grub screw? Although on a CoreXY I would expect that to cause a diagonal shift.

    How large is the layer shift?



  • @dc42 its a fresh build all pulleys are tight as hell. I add a picture of the problem.15868621740922850180193943979749.jpg its pretty small but happend 4 Times in a row on a exactly same height.



  • Check the Z axis. If it happens at the same height every time, something may be causing the bed to shift laterally. If you print something taller, does the shift repeat?



  • @mrehorstdmd printed 150mm vase and some artefacts appeard around the top but the bed is completly flat with glass and everything is directly laying at the entire z axis frame. Frame is on 4 sets of wheels with 3 z lead screws. I think its impossible to shift entire bed frame to one side. Rails and wheels are completly clean



  • I don't know if you are using Marlin 2.0, but I've seen one suggestion:

    Try uncommenting //#define JUNCTION_DEVIATION in Configuration_adv.h; that will disable classic jerk and use the junction deviation math instead.

    Also, I've seen some people say that slowing down the speed helps some people, so you may try this as well.

    I look forward to seeing which one of these things worked for you.



  • @Hesus29 Bed flatness affects first layer adhesion, and not much else. Does the opposite side of the print in the picture have a concavity? Are you using an E3D V6 hot-end? - check that the heat-break is securely screwed into the heatsink- they can come loose easily because there's no good way to tighten them. If it's loose the heater block will wobble.



  • @dliving I'm using reprap firmware probably 3.0



  • @mrehorstdmd Heat-break almost stuck in Titan aero and volcano block is very tight impossible to unscrew without tools. Entire gantry is very stiff but heavy bcs of titan aero


  • Moderator

    With the belts disconnected from the motors are you able to move the print head smoothly over the entire range of movement?

    It would appear to be some binding is happening.

    Check the v slot wheel bearings by lightly resting a finger on it while moving them. You may be able to feel some roughness. I've had a few broken bearings that would roll smoothly most of the time and then occasionally get bound up and then release again. Taking them apart I found that some of the bearing balls had shattered.



  • @Phaedrux entire gantry is running smoothly everywhere in range. I'll check the bearings thanks. And i got another problem. I left the printer for 2 days. Nothing changed and printed a new cube for a test.... I got an ugly uneven layered cube... It looks like stretched belts or something? 1587016723028726541296325768824.jpg


  • Moderator

    The cube looks a little short too. Maybe just the angle. But if it's short, I would say you have an issue with the Z axis that deserves a closer look.



  • @Phaedrux cube have perfect 20.00mm X and Y dimensions are 20.4mm



  • @Hesus29 With the layers stacked so poorly it is pointless to check the dimensions. You have to get the thing to print precisely (layers stacked properly) before you bother with that.

    Print a tall rectangular solid (try something like 40x40x150) with 3 perimeters and maybe 15-20% infill. Set the line width equal to the nozzle diameter. Let it get at least 100 mm tall before you stop it. Take and post pictures that show all four sides of the print.

    While you're at it, post some pictures of the printer. Details count, so take a bunch of them from different angles showing the Z axis assembly, belt paths, etc.



  • Have you PID tuned the bed and what are you using for the build plate? Please be specific on the bed details. Provide the type of plate you are using, heater and all layers including the print surface.



  • So guys i just dissasembled entire axis for gantry and assembled again. Tensioned belts a little bit less and got this. 15873131242344069487980823404723.jpg

    I think problem is solved? Idk what caused this thing


  • Moderator

    @Hesus29 said in CoreXY layer shift but only in one direction:

    Idk what caused this thing

    Friction is the enemy of mechanical freedom.