Setting up Z Probe M558 problem



  • I need help setting up my BLTouch 3.1
    When I add the code M558 P9 F100 H5 R0.2 T6000 A5 B1 it sets the Z-probe to 1000. When i add the I1 to invert the signal it goes to 0. All the actions, drop pin, raise pin, test, and reset all work. The issue is when I go to home the z-axis, it never triggers. I set it up using BeTrue3ds set up and changed P5 to P9.
    Let me also add that this issue started when I added a Mosquito hotend and thermister.
    Any help would be appreciated.


  • Moderator

    What firmware version are you using? Which board?
    Post your config.g and homeall/homez



  • Config.g
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"FT-5" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X32 Y32 Z32 E32 I1 ; configure microstepping without interpolation
    M92 X161.61 Y160.00 Z797.26 E832.28 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X1100 Y1200 Z1200 E1000 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X300 Y300 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M307 H7 A-1 C-1 D-1;
    M558 P9 F100 H5 R0.2 T6000 A5 B1 ;
    G31 P25 X20 Y0 Z0.0 ; Z probe trigger value, offset in relation to nozzle. And trigger height adjustment
    M557 X25:285 Y15:285 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4267 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    Homeall.g
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-305 Y-305 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-305 Y-305 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X40 Y15 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    Homez.g
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X40 Y15 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    Thanks


  • Moderator

    @Phaedrux said in Setting up Z Probe M558 problem:

    What firmware version are you using? Which board?

    I say again...


  • Moderator

    @Skater said in Setting up Z Probe M558 problem:

    The issue is when I go to home the z-axis, it never triggers.

    Have you tried the static test described here? https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe

    Are you saying that triggering the pin during a G30 move does not stop the movement?



  • Board is Duet Wifi 1.04
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.05.1 (2020-02-09b1)
    Duet WiFi Server Version: 1.23

    The issue is the input for the probe is always high. So when the probe is started it stops right away.
    The probe input is high even when there is no probe attached. I did not have this problem before I added the new thermistor.

    Thank you for helping so far


Log in to reply