Z probe offset - off edge of bed...



  • Hi,
    I'm wiring a duet2 wifi up to an X5SA

    All sensors and probes now seem to be working (though I think I killed one PWN fan channel...luckily I only need two!)

    However, when the print head is at X=0, Y=0, the Z probe is off the side of the bed - which means when I do a home, the Z probe never detects

    Does anyone know the appropriate gcode to tell the Z probe to home with an offset of say Z=50, Y=50?

    M558 P5 X50 Y50 F500 T5000 H3

    But this doesn't seem to have any effect...



  • @dbrb2 Needs to be done from your G31 IIRC

    HTH
    Paul



  • I had tried some G31 variations

    The duet uses the offset here to set the X and Y position when the endstops are hit - but in my case this puts the Z sensor off the edge of the board - so after homing X and Y it will need to move in bot h X and Y before homing Z...



  • OK, I home Z in the middle of the bed. I have an Ender3 Pro and a Hangtight Titan Aero mount, so my Y is off the bed.
    My homez.g

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.6 on Mon Jan 13 2020 17:26:38 GMT+0000 (Greenwich Mean Time)
    G91              ; relative positioning
    G1 H2 Z5 F6000   ; lift Z relative to current position
    G90              ; absolute positioning
    G1 X122 Y122 F6000 ; go to first probe point
    G30              ; home Z by probing the bed
    

    Let get you homing Z first.

    Please post your config.g just so we know if you are using RRF2 or 3
    And a M115, please

    Regards,

    Paul.



  • Ah - some progress:

    I updated my homez.g to be similar to yours above, and can now home the Z fine - though I do get the following error:

    M280: Invalid servo index 3 in M280 command

    "Home All" though still crashes the z into the bed. I haven't yet worked out the relationship between the homez.g, homey.g, homez.g, and homeall - It doesn't look like "homeall.g" simply calls he first three in sequence....

    My config.g for z probe is:

    ; Z-Probe
    M558 P5 I1 H5 F120 T6000                ; set Z probe type to inductive and the dive height + speeds
    G31 P500 X50 Y50 Z5.0                   ; set Z probe trigger value, offset and trigger height
    M557 X15:290 Y15:290 S20                ; define mesh grid
    

    And M115 gives me:
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.05.1 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-02-09b1



  • @dbrb2 Please post your config.g and you homez.g
    Bits of config.g does not help us 🙂

    What probe do you have, BL Touch or something else?

    Regards,

    Paul.



  • It's an NPN inductive probe. It seems to trigger OK at present when I use "z home" - but "home all axis" causes dthe probe to crash into the bed when it gets to Z - so "home all" doesn't seem to make use of the "homez" gcode....

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Thu Apr 23 2020 19:55:13 GMT+0100 (British Summer Time)
    
    ; General preferences
    G90                                     ; send absolute coordinates...
    G21                                     ; use mm
    M83                                     ; ...but relative extruder moves
    M550 P"TronXY X5SA"                     ; set printer name
    
    M669 K1                                 ; select CoreXY mode
    
    ; Network
    M552 S1                                 ; enable network
    M586 P0 S1                              ; enable HTTP
    M586 P1 S0                              ; disable FTP
    M586 P2 S0                              ; disable Telnet
    
    ; Drives
    M569 P0 S1                              ; physical drive 0 goes forwards
    M569 P1 S1                              ; physical drive 1 goes forwards
    M569 P2 S0                              ; physical drive 2 goes forwards
    M569 P3 S0                              ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                        ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z1200.00 E420.00      ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00     ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00     ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30            ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                 ; Set idle timeout
    
    ; Axis Limits
    M208 X00 Y00 Z0 S1                      ; set axis minima
    M208 X310 Y310 Z380 S0                  ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 S0                           ; set active low endstops
    M574 Z1 S2                              ; set endstops controlled by probe
    
    ; Filament Run Out Sensor
    M591 D0 P1 C4 S1 ; Filament runout Sensor for Extruder E0 on E1 Endstop input P1 = signal HIGH.
    
    ; Z-Probe
    M558 P5 I1 H5 F120 T6000                ; set Z probe type to inductive and the dive height + speeds
    G31 P500 X20 Y20 Z5.0                   ; set Z probe trigger value, offset and trigger height
    M557 X15:290 Y15:290 S20                ; define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                        ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700             ; set thermistor + ADC parameters for heater 0
    M143 H0 S120                            ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700             ; set thermistor + ADC parameters for heater 1
    M143 H1 S280                            ; set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P2 S0 I0 F500 H-1                  ; set fan 2 as part cooling fan
    M106 P0 T45 S0.7 H1			; set fan 0 as our hotend fan
    
    ; Tools
    M563 P0 D0 H1 F2                        ; define tool 0 uses part cooling fan 0
    G10 P0 X0 Y0 Z0                         ; set tool 0 axis offsets
    G10 P0 R0 S0                            ; set initial tool 0 active and standby temperatures to 0C
    
    
    ; Custom settings are not defined
    
    
    


  • Have you seen this guide?
    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe

    Please post homeall.g and homez.g

    We will get there!

    P.



  • I think I am getting there - a "home z" now works, as does a "auto bed level compensation"

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Thu Apr 23 2020 19:55:13 GMT+0100 (British Summer Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X50 Y50 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position

    ;G90 ; absolute positioning

    However, a "homeall" complains that I have homes insufficient axis (even if run just after a sucesful home X and Y)

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Thu Apr 23 2020 19:55:13 GMT+0100 (British Summer Time)
    G91                     ; relative positioning
    G1 H1 X-335  Y-335      ; move quickly to X or Y endstop and stop there (first pass)
    G1 X5 Z5 F6000          ; go back a few mm
    G1 H1 X-335 F360        ; move slowly to X axis endstop once more (second pass)
    G1 H1 Y-335 F360        ; move slowly to Y axis endstop once more (second pass)
    G1 X50 Y50		; Move z probe over bed
    G1 H1 Z-405             ; then move slowly to Z axis endstop
    G1 H1 Z5 F6000          ; lift Z relative to current position
    G1 H1 Z-335 F1800       ; move Z down stopping at the endstop
    G90                     ; absolute positioning
    
    

    In addition, the M280 z probe error still occurs - but from what I had seen of the guide you suggested, I had set the probe up as a type 5, which I think is correct....



  • @dbrb2 as long as the individual homing buttons work, ie homex y and z, you should be able to use this.

    Rename homeall.g to OLDhomeall.g

    Create a new homeall.g and put the following lines in it.

    M98 P"homex.g"
    M98 P"homey.g"
    M98 P"homez.g"
    

    Regards,

    Paul



  • @PaulHew Cheers - I'll give it a go first thing in the morning



  • Thanks - that worked

    And the M280 issue is also resolved - I had a deploy and retract probe file, but the inductive probe is always in place - so this was referring to a servo that did not exist

    Cheers!



  • @dbrb2 Pleasure, That is what the forum is for!

    Regards,
    Paul



  • @PaulHew thanks
    Mechanically and electrically all now works. Something I suspect though is wrong in my config still. My 20mmcalibration cube gets this far:

    cube.jpg

    Which doesn't look great, before reliably lifting from the bed entirely. I have set Z quite a few times, and checked the bed temperature. This isn't a problem I had with the old stock board, so I suspect the issue is with my config....perhaps something to do with my extruder settings:

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+4:+Calibration/40#s165

    I'll double check them. Will get there though...try again tomorrow!


Log in to reply