Motors not moving on delta printer with duet wifi



  • Hi

    Ive just assembled a delta printer and am in the latter stages of setup. Everything is connected and ive used the configuration tool to set the perameter's. However, try as i might, i cannot get the motors to move. i've been through the forum and tried all suggestions but to no avail. M122 spits out this:

    === Diagnostics ===
    Used output buffers: 3 of 32 (8 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.19.2 running on Duet WiFi 1.0
    Board ID: 08DDM-9FAM2-LW4S4-6J9D6-3SD6K-12S3X
    Static ram used: 21176
    Dynamic ram used: 96080
    Recycled dynamic ram: 1528
    Stack ram used: 1304 current, 4888 maximum
    Never used ram: 7400
    Last reset 00:01:44 ago, cause: power up
    Last software reset reason: User, spinning module GCodes, available RAM 7400 bytes (slot 4)
    Software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 40.5, current 42.9, max 43.3
    Supply voltage: min 24.5, current 24.6, max 24.9, under voltage events: 0, over voltage events: 0
    Driver 0: standstill
    Driver 1: standstill
    Driver 2: standstill
    Driver 3: standstill
    Driver 4: standstill
    Date/time: 2020-05-04 20:14:40
    Slowest main loop (seconds): 0.005512; fastest: 0.000034
    === Move ===
    MaxReps: 0, StepErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heater = 0, chamber heater = -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point
    WiFi firmware version 1.19.2
    WiFi MAC address 60:01:94:73:56:37
    WiFi Vcc 3.11, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 39552
    WiFi IP address 192.168.1.128
    WiFi signal strength -51dBm
    Reconnections 0
    HTTP sessions: 1 of 8
    Socket states: 2 0 0 0 0 0 0 0
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)

    i cant see where i,m going wrong, any help would be appreciated


  • Moderator

    Please post your config.g.

    What firmware version are you using?

    How are you trying to move the motors?



  • Hi, thanks for the reply

    Heres the config.g file

    I bought the duet wifi over 18 month ago but only just got it out of the box. The firmware was v1.19. I tried to move the motors prior to updating to the latest last night, resulting with no change in the situation.

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sun May 03 2020 15:31:27 GMT+0100 (British Summer Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name
    M665 R198 L360.22 B198 H500 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E663.00 ; set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00 ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; set minimum Z

    ; Endstops
    M574 X1 Y1 Z1 S0 ; set active high endstops

    ; Z-Probe
    M558 P5 R0.4 H30 F1200 T6000 ; set Z probe type to effector and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 R85 S20 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • @dwmee

    How are you trying to move the motors?

    They won't move without being homed, unless you issue M564 H0.



  • Thanks for the reply

    Ive just tried your suggestion M564 H0. I get the response - Movement outside the bed is not permitted.



  • If i try any move, like G1 Y10 for example i get this response:
    M120
    G91
    G1 Y10 F6000
    M121
    Attempt to move the head of a Delta or SCARA printer before homing the towers



  • By the way, despite saying i updated the firmware, it still appears to be on:

    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.19.2 (2017-09-01)
    WiFi Server Version: 1.19.2
    Web Interface Version: 1.19.3



  • @dwmee

    you could try to temporarily home the axis
    G92 x0 y0

    Before you do so, move the head so the carriages are in the middle of the travel on the towers and the head is in the centre. I would suggest doing that with the power off.

    You also need to change your endstops from M574 x1 y1 z1 s0 to M574 x2 y2 z2 s0. This is because the endstops are at the top of the towers at the maximum travel.



  • @jay_s_uk said in Motors not moving on delta printer with duet wifi:

    G92 x0 y0

    Thanks for the suggestions

    However, I still have no movement


  • administrators

    The correct way to test the motors on a delta printer is described on the delta printer configuration wiki page, https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareDeltaPrinter#Section_Testing_the_motors_and_endstops_individually.



  • Hi dc42 & jay_s_uk

    Thank-you for your help and guidance. I have managed to update the firmware to the latest & all seems to work as it should. Continue to be helpful &awsome

    Regards dwmee


Log in to reply