Show E0 thermistor & bed/hotend pt100



  • Hi!

    I use pt100 for bed and e0 but I want to see the temperature of a NTC3950

    Ofc I can make it work setting it as P0 or P1 but that hides the bed or the e0 temperature.

    What I want it’s to see on the control the e0 (doing temperature analysis of a new hotend heatsink).

    M305 P0 X200 R400
    M305 P1 X201 R400

    M305 P2 T100000 B3950 R4700 X1 ;?

    If I do this why I can’t see it as a new sensor? It’s because there’s no heater connected to this P2? How can I make it show it to me on the panel? I did google and check the wiki but didn’t found a way to force it. Thanks for your time!! (if I set thr P2 as P0/P1 I can see it but as said before I want to keep the pt100 bed heater on while testing the readings)



  • Where is your NTC3950 connected to? If to E1 temp connector, then your M305 P2 ...line should work if you take off X1 parameter from it.



  • @aidar

    Fixed it. Was as simple as adding the tool 2 on the duetpanelcontrol. It disappears after a reset but now I can see the temperature of the sensor without problems 😄 thanks!


Log in to reply