Duet Web control keeps failing to upload gcode files.



  • Re: Can't upload gcode files - Duet Web Control

    I have run into the same issue as others of gcode files failing to upload. I figure its a connection problem, but not sure what to do about it. I am running the Duet 3 via ethernet with the latest firmware. It seems to do it at random and sometimes, when I refresh the page, it works, other times not so much. Any help would be great.

    I also have this output from M122;

    M122
    

    === Diagnostics ===
    RepRapFirmware for Duet 3 MB6HC v0.6 or 1.0 version 3.0beta12 running on Duet 3 MB6HC
    Board ID: 08DJM-956L2-G43S8-6J9DL-3SN6Q-1S0GG
    Used output buffers: 1 of 32 (7 max)
    === RTOS ===
    Static ram: 122240
    Dynamic ram: 172764 of which 20 recycled
    Exception stack ram used: 960
    Never used ram: 97232
    Tasks: NETWORK(ready,456) HEAT(blocked,1208) CanReceiv(suspended,3804) CanSender(suspended,1428) CanClock(blocked,1428) TMC(blocked,80) MAIN(running,3460) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 08:04:35 ago, cause: software
    Last software reset at 2020-05-07 00:26, reason: User, spinning module GCodes, available RAM 97216 bytes (slot 3)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0442b000 BFAR 0x00000000 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 25.0MBytes/sec
    SD card longest block write time: 10.8ms, max retries 0
    MCU temperature: min 33.6, current 37.8, max 42.5
    Supply voltage: min 11.8, current 12.2, max 12.3, under voltage events: 0, over voltage events: 0, power good: yes
    12V rail voltage: min 11.3, current 11.5, max 11.7, under voltage events: 0
    Driver 0: standstill, reads 60532, writes 27 timeouts 0, SG min/max 0/390
    Driver 1: standstill, reads 60533, writes 27 timeouts 0, SG min/max 0/388
    Driver 2: standstill, reads 60535, writes 27 timeouts 0, SG min/max 0/826
    Driver 3: standstill, reads 60544, writes 19 timeouts 0, SG min/max 0/434
    Driver 4: standstill, reads 60553, writes 11 timeouts 0, SG min/max 0/0
    Driver 5: standstill, reads 60555, writes 11 timeouts 0, SG min/max 0/0
    Date/time: 2020-05-07 08:31:24
    Slowest loop: 14.07ms; fastest: 0.25ms
    === Move ===
    Hiccups: 0, FreeDm: 375, MinFreeDm: 356, MaxWait: 158054ms
    Bed compensation in use: mesh, comp offset -0.030
    === MainDDARing ===
    Scheduled moves: 112381, completed moves: 112381, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.0
    Heater 1 is on, I-accum = 0.6
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    lcd is idle in state(s) 0
    spi is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 19.12ms; fastest: 0.03ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • Ethernet -
      State: 5
      Socket states: 5 2 2 2 2 0 0 0
      === CAN ===
      Messages sent 116303, longest wait 0ms for type 0
      === Linux interface ===
      State: 0, failed transfers: 0
      Last transfer: 29075461ms ago
      RX/TX seq numbers: 0/1
      SPI underruns 0, overruns 0
      Number of disconnects: 0
      Buffer RX/TX: 0/0-0


  • Not sure how to interpret all that, but I have found that the Duet2 board will have problems uploading files as the uSD card on the board fills up. It never sends an error message to the console that the card is full, but transfer will slow to a crawl, and then fail after a portion of an upload. Try deleting some of the old gcode files.



  • I have seen that on my Duet2 WiFi board as well, but that's after I have about 40 or so files on there. This is different, I only have about 10-12 files on there.


  • Moderator

    @enix said in Duet Web control keeps failing to upload gcode files.:

    3.0beta12

    There were some network issues with beta 12 if I recall. I would suggest taking the card out and putting an the updated bin files from the 3.0 release zip file and then sending the gcode command to initiate a firmware update.

    If that doesn't work, you can use bossa on your PC to flash the updated firmware directly.



  • @Phaedrux

    Thank you for the reply, I have tried to re-upload a new bin file, but it still has the same version number in it. I tried to get a new file from the online configuration tool, but it also shows the same version. Is there another place to grab a different release?


  • Moderator

    @enix https://github.com/dc42/RepRapFirmware/releases/

    All firmware releases are here. The latest 3.01 RC version should be fine for you, or use 3.0 stable.

    Ian



  • Thank you for all responses. So far, updating to 3.1.1 worked.


Log in to reply