Inconsistent z axis heights



  • Hey all,

    Im still in the process of setting up my robo3d onto the duet 2 wifi,

    Im finally at the point where i can mesh level the bed. Only when i try the z axis starts off at a normal height but mid way through the mesh level it stops because the zprobe has already been triggered.

    Also my z heights are controlled by 2 motors and occasionally the carriage becomes out of level.

    And advice?



  • @joehsmash Please post your config.g and results from M115

    Regards,
    Paul.



  • @PaulHew

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Thu May 07 2020 17:04:03 GMT-0600 (Mountain Daylight Time)

    ; General preferences
    M80 ; Turns on the ATX power supply
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"JoehBo3D" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z800.00 E743.38 ; set steps per mm
    M566 X900.00 Y900.00 Z24.00 E240.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X9000.00 Y9000.00 Z100.00 E10000.00 ; set accelerations (mm/s^2)
    M906 X935 Y935 Z935 E935 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X228 Y254 Z203 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M558 P1 H5 F-120 T6000 ; set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X-24 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H1 T45 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1:1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings

    And the M115

    5/10/2020, 9:13:26 PM M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.05.1 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-02-09b1



  • so far i have verified all of my settings with my old firmware, with regards to speeds, and movement settings.

    when i push it to move 5mm it moves 5 mm, or 10.

    all my belts are tight, as well as bolts and carriages are level


  • Moderator

    What type of probe are you using?

    You can use the probe to level the gantry if you switch to using two independently driven motors.
    https://duet3d.dozuki.com/Wiki/Bed_levelling_using_multiple_independent_Z_motors



  • @Phaedrux will this work even though i have both z axis motors plugged into the same z output? what i mean is that on the duet 2 wifi, there are 2 spots to plug in 2 motors.

    edit,

    i am using a optical ir probe, i initially had it installed on the z endstop, but seeing as its a smart probe i just plugged it into the probe header



  • @Phaedrux also i think this might overlap with my other post



  • @Phaedrux also another edit, i see that reading the gcode that it requires me to plug my second motor into e1. as if another extruder. i will try this.

    how do i set up the e1 as a z motor though, i assume i will have to copy over all of the same settings (ie speed... etc) for the e1 motor



  • Alright so ive gone through the process of getting my second z axis motor running off e1, i will try some more in the morning


  • Moderator

    Sounds like you managed to figure it out. Let me know if you have any further issues.


Log in to reply