12864 LCD Selector knob not functioning



  • Hi
    I am unable to resolve this issue where LCD appears to be fully functional but using selector know I am unable to move between sections (image and video attached)

    I have Duet Maestro 1.0 board
    Firmware 2.05
    DWC 2.0.4
    I wired EXP1 and EXP2 on Duet to EXP1 and EXP2 on LCD. Using ribbon cable and changing the orientation of the recess slot on LCD

    LCD is my original Ender 5 LCD and was fully functional
    my config file command:
    ; Custom settings
    M918 P1 E2 ; Enable 12864 LCD with 1 menu item per encoder click

    I have tried -4, 4, 2 and -2 and only with 2 i have some function with other para no function when selecting or moving selector knob.
    IMG_2377[10515].jpg
    What am I missing

    Link to video: https://we.tl/t-EwDc209WlB
    Thanks


  • administrators

    I think it's trying to move between Babystep and Pause, but you have the pulses per click value set too low in your M918 command in config.g. If you are using 2, try 4.



  • @mladen001 said in 12864 LCD Selector knob not functioning:

    I have tried -4, 4, 2 and -2 and only with 2 i have some function

    I have used "M918 P1" (without E-parameter ) for a long time on RRF 2.
    As far as I can remember I had also issues when E was set...



  • Thanks both
    I have tried all combination of E and only with E2 I get the effect shown on img and video. All other values (4,-4,-2) produce no action when selector knob is rotated in either direction or when it is clicked. On E2 click works but selector knob is unable to select a heading so it is stuck and produces that ghosting you see on the image and video.

    I set the board originally with firmware 2.02 and this behavior was the same as it is now that I upgraded to 2.05
    I connected back to Creality board and both LCD and selector knob behave as designed.

    I hope someone can help to resolve this

    thank you


  • administrators

    Strange, if it does something when you use E2, then when you use E4 it should do the same thing except that you may have to move the knob 2 clicks instead of 1 to make anything happen.

    How many of the items on that menu are supposed to be selectable? Did you compose the menu file yourself, if not then where did you get it from?



  • I got the files from https://github.com/mudcruzr/Duet-Maestro-12864-Menu-Files/releases
    Other than renaming main and heat files (BTW also ran with original main & heat files same issue) I have left all files as provided.

    thanks



  • I would double check the ribbon cable connections as explained in the following thread ....

    https://forum.duet3d.com/topic/7609/configuring-12864-lcd-on-maestro/67?_=1589567721607



  • f409653e-0ef3-4552-a7a2-d11377bbf6a9-image.png


Log in to reply