after days of test prints the board wont respond this morning.



  • so i made some tests prints with this already and it worked ok. i went to do some more today and i cant connect to the DWC and when i connect to the board with a cable it shows up as a usb serial device nothing else and wont allow me to connect with yat. ive already gone thru this link

    https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond

    and here it says that if it shows up as a bossa port thats how i know i need to flash new firmware again, which ive done before and is a pain. but this link doesnt say anything about if it shows up as a usb serial device, which is what mine is doing. everything seems to be working exactly how it should, im sure im using a data connection cable it does the same thing with the 3 dif ones i have. any help would be appreciated



  • It's possible that simply the SD card is corrupt and needs to either be re-formatted or replaced and the files put back on it.

    I make sure to copy my sd card whenever I make changes to it just having DWC zip the files and I download them on my computer just in case.

    The usb serial device could also be considered an "unknown device" as listed in the link you posted. Did you try updating the driver for that usb serial device with the drivers for the duet?



  • @JamesM i do have the files backed up from when i re formatted it the first time so i will try that. it does ask me if i want to update the driver but it asked me that before as well and i didnt pay much attention to it.



  • lol idk why i didnt think to just re apply the sd card files, worked right away. i must need a new one because i dont know what would cause files to just disappear from it, thakns m8. been too many times ive looked over the easy stuff.



  • @zshoe I would get a new SD card of good quality just to be safe. They are a consumable item so it's best to have a spare or two on hand.


Log in to reply