DWC 3.1 on RRF3 - No Axis Home Icons on DWC Dashboard



  • Installed DWC 3.1 w/ rrf3 - new duet wifi 2. Cartesian Prusa [ Zaribo ]

    Trying to home axis - get errors [ G28 - Failed to Home ] - using sensorless homing.

    Tried using G28 X0 / G28 Y0 - since the DWC dashboard options do not exist ...


  • administrators

    It sounds like you are running a Delta configuration because DWC hides the individual axis home buttons for that kinematics option. Please share your config.g and I'll check your problem.



  • Thanks Chris,

    CONFI below...Steve (SputnikOCDd) is helping me

    General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"ZARIBO 2" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S1 ; enable FTP
    M586 P2 S1 ; enable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M667 S0 ; Cartesian Movement Mode
    M584 X0 Y1 Z4:2 E3 P3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E830.00 ; set steps per mm
    M566 X600.00 Y600.00 Z30.00 E3000.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X10800.00 Y10800.00 Z720.00 E4000.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z200.00 E4000.00 ; set accelerations (mm/s^2)
    M906 X600 Y600 Z600 E600 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y-3 Z0 S1 ; set axis minima
    M208 X254 Y210 Z205 S0 ; set axis maxima

    ; Endstops
    M915 XY F0 S0 H200 R1 ; configure stall detection for sensorless homing
    M574 X1 Y1 S3 ; Set endstops controlled by motor load detection

    ; Z-Probe
    M950 S0 C"exp.heater3" ; assign GPIO port 0 to heater3 on expansion connector, servo mode
    M558 P9 C"^zprobe.in" H3 F400 R0.2 A5 T10800 ; Set Z probe type to switch and the dive height + speeds
    G31 X28 Y5.6 Z1.68 P25 ; Set Z probe trigger value, offset and trigger height
    M557 X28:240 Y6:203 P5 ; Define mesh grid

    ; Heaters
    M140 H0 ; define bed heater
    M143 H0 S125 ; set bed heater max temp
    M308 S0 P"bedtemp" Y"thermistor" T100000 B3950 ; bed temp thermistor settings
    M950 H0 C"bedheat" T0 ; bed heater pin name

    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.06e-8 ; E0 hotend thermistor
    M950 H1 C"e0heat" T1 ; E0 pin name

    ; Fans
    M950 F0 C"fan0" ; part fan
    M950 F1 C"fan1" ; extruder fan
    M106 P0 S0 H-1 ; part fan not temperature controlled
    M106 P1 S1.0 H1 T45 ; extruder fan temp controlled at 45C

    ; Tools
    M563 P0 D0 H1 ; Define tool 1
    G10 P0 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P0 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss


  • administrators

    I just uploaded your config.g to my machine and tried to reload the web interface, and all the buttons are displayed correctly for me:

    99aa22b5-1bec-439d-b2c7-d207b32a35fb-image.png

    Please make sure that you are using the latest DWC 3.1.0 (see Settings -> General).



  • Screen Shot 2020-05-19 at 7.35.09 PM.png

    Thats is completely weird


  • administrators

    @Kiwi3D What does M409 K"move.kinematics" show?



  • @chrishamm said in DWC 3.1 on RRF3 - No Axis Home Icons on DWC Dashboard:

    M409 K"move.kinematics"

    Is that something I need to type, not sure of the question, sorry

    Ray


  • administrators

    @Kiwi3D Yes, type that in the G-code console and post the output here.



  • @chrishamm

    It's just scrolling

    Screen Shot 2020-05-19 at 8.42.54 PM.png


  • administrators

    @Kiwi3D That may explain it. Please install this firmware binary by uploading it on the System page and check if the problem persists. If it does, please try to send the M409 code again.



  • @chrishamm

    I got a result 2nd time
    M409 K"move.kinematics"
    {"key":"move.kinematics","flags":"","result":{"deltaRadius":105.600,"homedHeight":250.000,"name":"delta","printRadius":85.0,"towers":[{"angleCorrection":0,"diagonal":215.000,"endstopAdjustment":0,"xPos":-91.452,"yPos":-52.800},{"angleCorrection":0,"diagonal":215.000,"endstopAdjustment":0,"xPos":91.452,"yPos":-52.800},{"angleCorrection":0,"diagonal":215.000,"endstopAdjustment":0,"xPos":0,"yPos":105.600}],"xTilt":0,"yTilt":0}}


  • administrators

    My guess is that you have a config-override.g file in /sys on the SD card. Delete it (you can do that from DWC) and restart the Duet.



  • @chrishamm

    M409 K"move.kinematics"
    {"key":"move.kinematics","flags":"","result":{"forwardMatrix":[[1.000,0,0],[0,1.000,0],[0,0,1.000]],"inverseMatrix":[[1.000,0,0],[0,1.000,0],[0,0,1.000]],"name":"cartesian","tiltCorrection":{"correctionFactor":1.0,"lastCorrections":[],"maxCorrection":1.0,"screwPitch":0.50,"screwX":[],"screwY":[]}}}


  • administrators

    @Kiwi3D The second output looks correct. You should be seeing the axis home buttons again.



  • OK....so we have the right menus now

    And we now have motor movement

    Screen Shot 2020-05-19 at 8.51.38 PM.png



  • Thanks @dc42 and @chrishamm

    We now have a functioning homing system

    Appreciate you help

    and...@SputnikOC3d - thank you too dude!!!

    Cheers

    Ray


Log in to reply