Trouble uploading print from DWC



  • I've been printing several months now with Duet Wifi powered machine, but all of a sudden yesterday I started having trouble uploading gcode. Updated the firmware yesterday and that solved it yesterday, but I'm back to having the same issue today. Please advise.



  • Too many files on the SD card? There is a limit - can't remember what it is but using folders can overcome it. Bad file names used to be an issue -i.e DWC didn't like certain characters but I believe this is now fixed. Alternatively, corrupt SD card?



  • Thanks deckingman, I'll try freeing up some space.



  • Freeing up space in the gcode folder on the sd card didn't solve it.



  • Wow. I updated to 1.18.1 last night and while trying to resolve my issues tonight by searching the forum, I saw there is a 1.19 beta, so I tried to update to that and I can't upload that either.


  • administrators

    What sort of trouble are you having uploading files, and which Duet do you have?



  • dc42, once the printer is ready and I hit upload and print and select my file, the window showing upload progress doesn't open like usual. I'll get a bar at top of screen that says Chrome(my browser) isn't responding, then the upload window finally opens showing "error".



  • My issues have been resolved. It was a browser issue.


  • administrators

    Hi which browser were you using?


  • administrators

    Sadly, Chrome under Windows 10 is flaky. It used to crash on me occasionally and I would have to kill off all its background processes individually in Task manager before I could restart it. The latest version doesn't do that, but every so often it becomes completely unresponsive and I have to wait 30 seconds for it to recover. I've taken to using FireFox to control my 3D printers.


Log in to reply