Magnetic sensor V1.2 red led blink no pattern help needed



  • I have one of the first magnetic filament sensor,( Fialment Sensor v1.3 CERN OHL V1.2) worked like a charm till some weeks ago when it starts not responding anymore.
    Green led is followed but continuously red flashing led.
    The magnetic chip sensor was worn out by the friction with the magnet, so I bought a new chip sensor and changed it.
    I mounted the board and everything worked fine for some prints but today it started to give problems again.
    when I start the printer the sensor led flash green followed by almost fixed red led that starts to blink without a pattern as soon as I move the filament.
    On console I am having

    M591 D0
    Duet3D magnetic filament monitor on input 3, enabled, sensitivity 24.80mm/rev, allow 70% to 130%, check every 3.0mm, version 1, measured sensitivity 14.38mm/rev, min 43% max 330% over 15.1mm
    Duet3D magnetic filament monitor on input 3, enabled, sensitivity 24.80mm/rev, allow 70% to 130%, check every 3.0mm, version 1, measured sensitivity 14.38mm/rev, min 43% max 330% over 15.1mm
    Duet3D magnetic filament monitor on input 3, enabled, sensitivity 24.80mm/rev, allow 70% to 130%, check every 3.0mm, version 1, measured sensitivity 33.79mm/rev, min 100% max 100% over 12.1mm
    Duet3D magnetic filament monitor on input 3, enabled, sensitivity 24.80mm/rev, allow 70% to 130%, check every 3.0mm, version 1, no calibration data
    Duet3D magnetic filament monitor on input 3, enabled, sensitivity 24.80mm/rev, allow 70% to 130%, check every 3.0mm, version 1, no calibration data
    Duet3D magnetic filament monitor on input 3, enabled, sensitivity 24.80mm/rev, allow 70% to 130%, check every 3.0mm, version 1, no calibration data
    Duet3D magnetic filament monitor on input 3, enabled, sensitivity 24.80mm/rev, allow 70% to 130%, check every 3.0mm, version 1, measured sensitivity 14.38mm/rev, min 43% max 330% over 15.1mm
    

    So intermittent reading of (wrong) magnetic turn and no data.
    The chip is very very near to the magnet and the magnet rotates correctly during filament transit so I don't think my problem could be caused by a mechanical issue
    Here a video of led behavior https://youtu.be/mlX_6T4ZJus

    Also after upgrading the firmware to the last one when the printer goes in pause mode thinking of a filament jam I no more receive the message filament sensor report...) but I am having only a white popup with a clickable OK button on it.

    Scrrenshoot.jpg image url)

    I saw the sensor is still in out of stock status, is it possible to know when it will be available again?
    Is the form factor the same of the pre-production model?

    Board: Duet WiFi 1.0 or 1.01 (duetwifi10)
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.05 (2019-12-13b1)
    Duet WiFi Server Version: 1.23


  • Moderator

    What DWC version are you using? The dialogue box error may be from using DWC 3.1.1 with 2.05.

    May also way to update to 2.05.1



  • Thank you for your answer
    Duet Web Control 2.1.5
    Duet WiFi Server Version: 1.23
    Firmware 2.05


  • administrators

    @claustro said in Magnetic sensor V1.2 red led blink no pattern help needed:

    Duet Web Control 2.1.5

    Are you sure? I don't remember that version. Suggested versions of DWC ro use with RRF 2.05.1 are 1.22.6 or 2.0.7.

    Regarding your sensor, it's still running the original firmware, which doesn't report the AGC value. Do you have the means to program Atmel AVR chips?



  • Thank you for your replay, much appreciated is more than 2 months I am trying to fix my sensor.
    If I remember correctly I installed the latest version available of dec, 2.0.7 , but on the web page is listed as 2.1.5 check the screenshot.

    duet.jpg
    How can I downgrade (?) to 2.0.7 or 1.22.6

    Regarding programming AVR I have some usbasp laying around.


  • Moderator

    @claustro said in Magnetic sensor V1.2 red led blink no pattern help needed:

    How can I downgrade (?) to 2.0.7 or 1.22.6

    2.0.7 is included with the 2.05.1 release. You can upload the entire 2.05.1 zip file or just the 2.0.7 DWC zipfile.



  • @Phaedrux said in Magnetic sensor V1.2 red led blink no pattern help needed:

    2.05.1

    Maybe I need some clarification because I am missing something.
    I upload Duet2Firmware-2.05.1.zip took from here https://github.com/Duet3D/RepRapFirmware/releases/tag/2.05.1
    and now, in general tab , duet web control is listed as 2.0.4 and not 2.0.7

    Board: Duet WiFi 1.0 or 1.01
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.05.1 (2020-02-09b1)
    Duet WiFi Server Version: 1.23

    2.0.4.jpg


  • Moderator



  • thank you for your answer, I uploaded the DWC 2.0.7 and it is now updated I thought that 2.0.7 was already present in 2.05.1 main firmware zip file. thx



  • @dc42
    Any news for me?
    thank you
    Andrea


Log in to reply