Zoffset ignored duet wifi bltouch



  • Somehow I can't do babystepping and is my zoffset always the same. I mean my nozzleheight from the bed.

    Followed the bltouch z-offset guide and reports 1.447 is alway acurate. it always reports back this value after following the procedure. Bat after editing my config and rebooting Z0 is suddenly 3mm away from bed.

    No matter if I raise or lower z-offset is always stays 3mm away from bed.

    I am a bit puzzeled...

    My config:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Oct 09 2018 13:27:56 GMT+0300

    ; General preferences
    M80 ; Turns on the ATX power supply
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M669 K1 ; Select CoreXY mode

    ; Network
    M550 PBLV mgn Cube ; Set machine name
    M552 S1 ; Enable network
    M587 S"Bill Wi, the Science Fi" P"sjn8nmdvFyF9" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes backwards blv: its was S1
    M569 P1 S1 ; Drive 1 goes backwards blv: its was S1
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes backwards
    M584 X0 Y1 Z2:4 E3 ; Multiple Z; define Drive for Z
    M671 X-56.0:373.0 Y171.0:171.0 S5.0 ; Multiple Z; define position of leadscrew for probing Z
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100 Y100 Z400 E413 ; Set steps per mm for Bondtech.
    M566 X400 Y400 Z24 E2000 ; Set maximum instantaneous speed changes (Jerk) (mm/min)
    M203 X12000 Y12000 Z600 E2000 ; Set maximum speeds (mm/min)
    M201 X3000 Y3000 Z100 E5000 ; Set accelerations (mm/s^2)
    M906 X2000 Y2000 Z750 E750 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Pressure advance
    M572 D0 S0.05 ; disabled Pressure advance

    ; Axis Limits
    M208 X-14 Y0 S1 ; Set axis minima
    M208 X310 Y326 Z360 S0 ; Set axis max

    ; Endstops
    M574 X1 Y2 S1 ; Set active high endstops edit: Y endstop is high(max).

    ; Filament sensor
    :M591 D0 P1 C3 S1 ; Set Filament sensor Simple type (High) for extruder drive 0, connected to endstop input 3 (E0)

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1
    G31 P25 X28.5 Y-5 Z1.689 ; Set Z probe trigger value, offset and trigger height
    M557 X30:270 Y30:270 S40 ; Define mesh grid
    M558 P9 H5 F100 T6000 A5 B1

    ; PID
    M307 H1 A250.8 C94.3 D2.1 B0 ; Set PID for hotend values
    M307 H0 A116.2 C224.5 D5.5 B0 ; Set PID for heated bed values

    ; Heaters
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S100 ; Set temperature limit for heater 0 to 100C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S260 ; Set temperature limit for heater 1 to 260C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T35 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T35 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S21 R22 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured
    M564 H0 ; Let the Jog buttons work blv: added to allow jog buttons


  • Moderator

    @Caveman said in Zoffset ignored duet wifi bltouch:

    G31 P25 X28.5 Y-5 Z1.689 ; Set Z probe trigger value, offset and trigger height
    M557 X30:270 Y30:270 S40 ; Define mesh grid
    M558 P9 H5 F100 T6000 A5 B1

    M558 must come before G31

    Also post your homeall and homez.



  • ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Oct 09 2018 13:27:56 GMT+0300
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-355 Y355 F6000 ; move quickly to X or Y endstop and stop there (first pass)
    G1 S1 X-355 ; home X axis
    G1 S1 Y355 ; home Y axis
    G1 X5 Y-5 F6000 ; go back a few mm
    G1 S1 X-355 F360 ; move slowly to X axis endstop once more (second pass)
    G1 S1 Y355 ; then move slowly to Y axis endstop
    G90 ; absolute positioning
    G1 X152 Y166.4 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Oct 09 2018 13:27:56 GMT+0300
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X152 Y166.4 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • ok changed m558 now bed position suddendly changed?


  • Moderator

    @Caveman said in Zoffset ignored duet wifi bltouch:

    ok changed m588 now bed position suddendly changed?

    What do you mean by that?



  • I moved m558 above G31, now as I ask ;

    bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Oct 09 2018 13:27:56 GMT+0300
    ;G28 ; home all
    G30 P0 X20 Y150 Z-99999 ; probe near a leadscrew, half way along Y axis
    G30 P1 X240 Y150 Z-99999 S2 ; probe near a leadscrew and calibrate 2 motors
    G30 P0 X20 Y150 Z-99999 ; probe near a leadscrew, half way along Y axis
    G30 P1 X240 Y150 Z-99999 S2 ; probe near a leadscrew and calibrate 2 motors

    But it now probes @ x-8.5 and x211,5 and also printing has moved a little to the left.
    This happened after moving M558


  • Moderator

    Well your probe offset wasn't being applied before.



  • true but purge line now happens outside of bed and prints to the left. So something needs changeing i guess


  • Moderator

    I suggest you revisit your M208 values. 0,0 should place the nozzle at the front left corner of the printable area, measure the distance to the ends of travel from there.

    Easiest way to do that is to first send M564 H0 S0 to allow you to move the print head anywhere and without needing to home. Then manually place the nozzle at the front left corner. Then send M92 G92 X0 Y0 to force the current position and then jog the print head to the extents of travel and note the values in the position display for use in M208. Careful not to ram into the frame.

    Also be sure to measure your probe XYZ offset as described here: https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe#Section_Measuring_Probe_X_Y_Offset

    With those re-established you may need to revisit any existing G1 positional moves you may already have in your macros to make sure they actually go where you want them to.



  • Thanks I wil do that after print is finished. Thanks a lot for the help!!!



  • @Phaedrux strange I have tried this but with m92 command the x axis does not change. It stays the same.


  • Moderator

    @Caveman said in Zoffset ignored duet wifi bltouch:

    m92

    I'm sorry, that should have been G92, not M92.

    G92 forces a position. M92 is for steps per mm.



  • So do I need to save the new 0.0? I managed to get it to 0 but when I start a print it changes back.



  • Do I need to move head in every direction and check values?


  • Moderator

    Well when you find the values you'll need to modify the M208 commands in config.g to make them permanent.



  • Thanks I have it perfect now. Thanks a lot. No I just make sure all the coordinates in macros and so on are in the correct place and all is good.


Log in to reply