Toolchanger running very slowly, stopping to think!



  • As part of the commissioning following the E3d guides, I ran the included Benchy gcode. The guide suggests the print will take about 1 hour. I stopped mine after 3 hours when it still had'nt completed the bow.

    The problem seems to be the machine stops completely between different actions, for example stopping for a noticeable time between each layer of a perimeter at the seam point, or pausing between perimeters and infill or even different lengths of infill.

    I'm using the config.g put on the Web (https://github.com/Duet3D/RRF-machine-config-files) by dc42 with a max X and Y of 35000mm/mon, 6000mm/s^2 acceleration on Xand Y and the Benchy.gcode by Greg Holloway, so it shouldn't be affected by any 'wrong' settings in my slicer. Even so, on a 100mm *5mm annulus I see a maximum of 34mm/s on perimeters and 6mm/s on infill which seems slower effectively that my Mk2 Prusa ( the threaded rod version) on a duet 0.6 and RRF2

    I'm looking at the post elsewhere for tuning macros,(https://forum.duet3d.com/topic/6181/tuning-macros-menus-accel-jerk-retraction-pressure-advance) but is there something obvious I'm missing, or are my expectations simply too high?


  • Moderator

    Can you share that benchy.gcode?


  • administrators

    The settings suggested by E3D include a very low extruder jerk value, with together with the suggested pressure advance makes for very slow acceleration. You can see the settings I use at https://github.com/Duet3D/RRF-machine-config-files/tree/master/E3D_Tool_Changer.



  • @dc42 I am using the Toolchanger config.g that you provided (in a different thread to someone else some time ago, before the current repository) for 4 titans but not centred. There were still changes you were making I think as I still get the occasional message that I should replace a "G1 S" code with G1 H in various macros. I will look at your later version and make adjustments.





  • @dc42 here are the relevant sections from the two config.g 's :

    The config.g currently installed :

    M566 X400 Y400 Z8 C2 E2:2:2:2 ; Set maximum instantaneous speed changes (mm/min)

    M906 X2000 Y2000 Z1330 C500 E1600:1600:1600:1600 I30 ; Set motor currents (mA) and motor idle factor in percent

    M572 (pressure advance is set to 0.2)

    from config.g on https://github.com/Duet3D/RRF-machine-config-files/commit/572c88b12434605074ecec756357c4c555f0a0d0

    M566 X400 Y400 Z8 C2 E200:200:200 ; Set maximum instantaneous speed changes (mm/min)

    M906 X2000 Y2000 Z1330 C500 E1400:1400:1000 I30 ; Set motor currents (mA) and motor idle factor in percent
    M84 S120

    The only significant difference (ignoring the Hermera specifics) is that your extruder jerk is set to 200 and mine is set to 2, Other values were identical

    I had assumed that should only affect the rate of change of extrusion, not rate of change of position, but your comments in the Readme suggest other wise "The extruder jerk setting has not yet been optimised. Too low a setting results in slow printing when pressure advance is used. Too high a setting makes the Titan extruders noisy and may cause hot end jams."

    So , since I was in the middle of a print that so far had taken 23 hours so far, I sent
    M566 E200:200:200:200

    The result was instantaneous, the layer time fell from 3min 44 to 1 min 22 and the extruder motor was noticeably warm to the touch

    M906 E1600 I30 reduced the noise level and temperature somewhat

    A successful intervention.


  • administrators

    @robinS3 said in Toolchanger running very slowly, stopping to think!:

    @dc42 I am using the Toolchanger config.g that you provided (in a different thread to someone else some time ago, before the current repository) for 4 titans but not centred. There were still changes you were making I think as I still get the occasional message that I should replace a "G1 S" code with G1 H in various macros. I will look at your later version and make adjustments.

    For Titan tools I currently use extruder acceleration 2500, max speed 5000, and jerk 200. I would like to use higher jerk but that makes some Titans noisy.


Log in to reply