Applying of high map (*.csv) during a print



  • Hallo everyone,
    I'm working to obtain the first prints from my cartesian.
    At the moment i do a G29 command, the duet saves a *csv map, and i can view the map with command from DWC (show map)
    it seem to be two thing not very clear.
    First problem is that the map seems to be, respect to the grid of the popup box, in the high position. (i have to scroll out a lot before see my map)
    It's like the map is read at the Z high limit from nozzle
    The second issue is that (may be due to a not written code) during the print, me Z axis doesn't move based on high of map recorded.
    I have a printer in my office, and during the print, z axis is continuously moving based on x Y position.
    I 'v seen in my slycer (Simplify3d) that is written a script to the start of program, in wich is called G29 before every print. But this seems dont have effect on the z movement.

    thanks for answers.


  • Moderator

    Can you post a photo of your heightmap being displayed so we can see what you mean?

    What firmware and DWC version are you using? Be sure you're using at least 2.05.1 and 2.0.7.

    The heightmap is only active right after G29 has been run, or if the saved heightmap has been loaded with G29 S1. So you need to either run G29 before the print, or you need to load the saved map with G29 S1 in your slicer start gcode.

    You can check to see if the correction is active by sending M122 and looking for the line :Bed compensation in use: mesh, comp offset 0.000



  • @Phaedrux thanks, tonight I will send a picture of hightmap. In a print I have written g29 s1 at the begin.. But the z offset for the layer was completely wrong.... why I don't see the action on the, z axis during that print? I can't believe that my bed is perfectly plane...

    Thanks again


  • Moderator

    Post your config.g and homing files as well as your slicer start gcode for the sake of completeness.



  • @logriso said in Applying of high map (*.csv) during a print:

    @Phaedrux thanks, tonight I will send a picture of hightmap. In a print I have written g29 s1 at the begin.. But the z offset for the layer was completely wrong.... why I don't see the action on the, z axis during that print? I can't believe that my bed is perfectly plane...

    Thanks again

    Are you performing a G30 before the G29?

    Frederick



  • Hallo,

    sorry for my late...
    @Phaedrux here the picture of my heighmap8e3eb519-a967-4939-bf5b-e9a1ef8c056e-image.png
    as you can see, seems that the reading of 24 points of probe is far from the base of printing.
    my config.g and homing :homeall.g config.g (could you explane to me how i can attach the files not in attachment to the message, but in text scrolling mode?) cube_.gcode
    Here the revision of my firmware and dwc
    759f78e8-b296-41a8-8f23-ea8fffeb5541-image.png

    @fcwilt ..No, I did not performed the G30. May be Im wrong but i have understand, that G30 was an old command to perform single probing point.

    Thanks again at all 🙂


  • Moderator

    G30 is not an old command, it is the means of using the probe to find the Z0 point. This must be established before the creation and loading of the heightmap, otherwise you will get an offset as you see.

    https://duet3d.dozuki.com/Wiki/Using_mesh_bed_compensation

    Since you have commented out the G30 you are not actually homing the z axis at all in homeall since you don't have an endstop movement either.

    G90                   ; absolute positioning
    G1 X0 Y0 F6000        ; go to first bed probe point and home Z
    ;G30                   ; home Z by probing the bed
    

    What type of probe are you using?

    You must also measure your probe offsets for the mesh to be accurate for the nozzle position.

    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe

    Also it would be a good idea to update to 2.05.1 firmware to get the benefit of the bug fixes since 2.03.

    To get the config posted as text, simply copy and paste it into the post. You can use ``` marks before and after the code block.



  • I'm using a proximity probe. But ht homing of z axis is not done by home Z from DWC interface?
    when i power on the machine, if I dont execute homeall from DWC i can move nothing..And the machine performs all axis home, X,Y and Z (at the far point from nozzle - where there is the limit swich


  • Moderator

    The buttons in DWC execute the homing macros. So does using G28, or G28 X Y or Z.

    If you are homing to zmax then you must be using homez for that because homeall has no commands to home Z at all.

    Homing to Z max is fine, but you must measure the length of the axis precisely and be aware that it will likely change with bed temperature. Using the Z probe measures the actual position of the Z0 which is far more reliable if the probe itself is reliable. The endstop at zmax will depend on the accuracy of your measurement of the z axis length from the actual bed surface and will be influenced by temperature, so it's harder to depend upon.



  • @Phaedrux ok thank you... I will change z home using g29 from home all...I have seen that the home is made to the opposite z limits...
    so if I have understood now is enough add g29 at the begin of the program to manage the planarity of the bed during the print?


  • Moderator

    @logriso I honestly don't understand what you're saying.

    Post your changes so I can see what you mean.



  • @Phaedrux sorry..may be I did not explain well...
    what i mean it was that :
    case 1) if i perform an home from the button of DWC, (button HomeALL->homeall.g) without enabling G30 the movement of the bed starts reaching the High limits of the axis, (that is far from the nozzle), where i mounted the mechanical Z limit switch.
    case 2) if i enable G30 in the file homeall.g, the home has done reaching the probe that i colse the nozzle.
    Now I added G29 in the fist part of my print code. I can see that duering a print the z axis moves based on the nozzle position (bed compensation) .
    I believe i have solved my problem

    Thank


Log in to reply