Filament Runout Sensor not working



  • Hi! I'm using a third party filament runout sensor, is consist of 3 wires, signal, voltage and ground. I'm running RRF 3.1.1. The sensor is connected it to the E0_endstop and in the config file I have the following:

    ;Filament Runout sensor
    M591 P2 C"e0_stop" S1

    I believe that my connection is correct since when filament is present I have a LED turned on in the sensor and on the board LED E0_stp is turned off as can be seen in the pictures below.
    IMG_20200604_161739.jpg
    IMG_20200604_153757.jpg

    Now, when there's no filament present, the LED in the sensor turns off and on the board the E0_Stp LED is turned on as can be seen below.

    IMG_20200604_153737.jpg
    IMG_20200604_160954.jpg

    So, from my perspective the connections are OK but there must be something wrong in my config.g since nothing happens, I've replaced also M591 P2 C"e0_stop" S1 with M591 P1 C"e0_stop" S1 and it is the same result. What am I missing? Please, any help would be really appreciated.



  • Try inverting the pin with an !
    e.g.
    M591 P1 C"!e0_stop" S1



  • @jay_s_uk Thanks for the tip but didn't work. I start a print job and it is the same, the print does not pause. I tried it both with what you said and also with M591 P2 C"!e0_stop" S1. What can be wrong?



  • It looks like you have the Lerge style sensor.(mine looks exactly the same)
    where you have it plugged into the board, reverse the plug so the white and red wires switch places.
    If the little white plastic piece on the pins interferes, you can easily remove it with needle nose pliers and a little wiggle.

    then i have this in the config
    M591 P1 C"e0_stop" S1

    When the filament is loaded the LED light on the Duet 2 beside the extruder pins is on.

    Hope this helps



  • rather it should be like this M591 D0 P1 C "e0_stop" S1



  • @g-biel @jay_s_uk @HtRabbit Sorry for replying so late, been busy. Many thanks guys, problem solved.


Log in to reply