Ethernet connection not seen in DWC or DM



  • I put the MAC address and DHCP address my router assigned to the DUET. HTTP is enabled, the board is plugged into the router and the router is plugged directly to my PC as well. yesterday it was seen in the Device Manager as COM6 and I connected with Proterface just fine, but couldn't use the DWC. Now I can't use either to see the board. What am I dong wrong? I'm so close to enjoying my printer again 🙂


  • administrators

    You don't need to do anything with the MAC address unless you have 2 or more wired Duets on the same network.

    First try to get the board running with Pronterface again. Does the COM port appear in Device Manager still when you connect the Duet?



  • NO it doesn't appear there now


  • administrators



  • Duet Ethernet firmware version 1.17 this is built with Emulsifide's Little Monster build configuration



  • I decided to try and start back at the beginning in case I messed something up. Now when I send M997 S0 it says "ERROR Firmware binary DUETETHERNETFIRMWARE.bin NOT FOUND". I'm feeling really lost. it seems the more reading I do the more off track I get. M997S1 give invalid module number. I also tried sending code from my slicer VIA USB, no luck 😞 I need a duet board set up for dummies. 😛



  • FYI I just came from using Smoothie, and very limited Marlin/Repetier before that on an i3. Now on a Delta ( that came with Smoothie knockoff board) very inconsistent prints. I was hoping this was the ticket for me.


  • administrators

    If you are doing a manual installation of firmware from the SD card, you need to put the firmware file DuetEthernetFirmware.bin in the /sys folder of the SD card, then run M997. Just as described at https://duet3d.com/wiki/Updating_main_firmware#Fallback_procedure_.231 except for the name of the firmware file.



  • okay, I got that done I believe. Now I still have the issue of the ethernet not showing up in COMs. I can connect by USB. I copied and pasted the net files in NP++ so I'm back at default settings. would it help if I uploaded the contents of my SD card so you could look at it? I'm hoping its not too big of a mess. Also can I do my calibrations etc up by USB until I figure out the ethernet part?



  • Working by USB it will take one command, I sent for BL Touch pin down, it did that. I got all happy. Then it wouldn't do anything. I disconnected and tried again. I made the pin go up, then dead again. so only one command? deep breath, le sigh

    tried D/L SAMBA but they want a confirmation and I never got an e-mail. I sent a message to the Webmaster. Considering the time of day I probably won't hear back from them today.



  • Network is enabled, config IP 192.168.1.14x actual IP 192.168.1.14x still not seen in Device manager. is found by the router



  • The Duet's ethernet connection won't show up in Device Manager, that's normal. You connect to it via a web browser.



  • I can't connect to DWC, it always says I'm in simulation mode.



  • Some functionality will not work as this simulation is not connected to a Duet running RepRapFirmware


  • administrators

    How are you loading DWC? You should be entering the IP address of the Duet in the address bar of Chrome or Firefox.



  • This is progress of sorts. I enter the number into the address bar, and I get a blank screen or it times out. I couldn't see the forest for the trees, The first hurdle was staring me in the face all day yesterday as I was going to the DWC sim page. I saved the link back when I first thought about getting the board. I must have assumed it was what I was trying to connect to.



  • when I put the address assigned by the router in the web browser it get a blank screen, the WWW folder is populated with the web control download. if I click refresh, the activity light on the Ethernet connection blinks at exactly the same time as I click.


  • administrators

    Does the contents of /www on the SD card look like this:



  • IS there code for finding out what is stopping the connection so I can fix it?




Log in to reply