Acceleration test - but the result doesn't change



  • Hello,

    I tried to do an acceleration test, but the result doesn't change.
    First test I printed with no gcode modification of the part.
    Second test.
    In the gcode, I added the M201 P400 before layer=0 and every five centimeters, I updated the code with M201 P800, M201 P1200, ....
    Between test one and test two, the parts are identical like the code M201 doesn't work.

    I read in the old post, that I need to add the M400 before each M201, I tried but same result.

    I have downloaded the part from the web interface.

    I'm a beginner, I think we have a PEBCAK issue 😊
    Thanks for helping me.

    Regards.



  • @houpdelta

    You are using the wrong g-code. M201 sets per-axis (X,Y etc). P (and T) is used with M204 to set acceleration when extruding or not.

    So:

    M201 X8000 Y8000
    M204 P4000 T8000

    Would limit acceleration while extruding to 4000mm/s/s. But allow travel moves to be at 8000mm/s/s
    But:

    M201 X4000 X4000
    M204 P4000 T8000

    Would mean that travel moves would still just be 4000mm/s/s.
    Check your base M201 values and try again with M204



  • Sorry, I made a mistake in my previous post.
    I have this in my gcode.

    ;Layer:0
    M400
    M201 X3000 Y3000
    M204 P400

    ;Layer:5
    M204 P800

    ;Layer:10
    M204 P1200

    ......

    ;Layer:25
    M204 P2400.

    regards.


  • Moderator

    Does your slicer have any acceleration controls enabled? Can you share the gcode file itself?





  • @houpdelta

    Whats the acceleration on your E axis? Its possible that's the limiting factor.


  • Moderator

    Yes please share your full config.g



  • You could find the config.g

    config.g

    it has been generated by the RepRapFirmware Configuration Tool.

    I just comment the lines M201, M203, M205 to do test.
    I used Cura to generate the gcode.

    Thanks.


  • Moderator

    @houpdelta said in Acceleration test - but the result doesn't change:

    I just comment the lines M201, M203, M205 to do test.

    Don't do that. It's no wonder there was no change in the printed file because you've removed the definitions for all motors.

    ;M201 X3000 Y3000 Z3000 E250.00:250.00              ; set accelerations (mm/s^2)
    ;M203 X6000.00 Y6000.00 Z180.00 E1200.00:1200.00    ; set maximum speeds (mm/min)
    ;M205 X900.00 Y900.00 Z12.00 E120.00:120.00         ; set maximum instantaneous speed changes (mm/min)
    

    Leave those in config.g. When you alter the value in the print file with M204 P T it will override the print move and travel acceleration the way you want and leave the other settings intact.



  • I just did the test on my duet 3 last night.

    I followed the same steps with the M204 after every x layers,

    BUT I also increased the global accel BEFORE the first M204 to make sure it's not limiting it.

    So the first line would be

    ; Layer = 0
    M201 X3000 Y3000
    M204 P400
    

  • Moderator

    Did you uncomment your speed settings in config.g?



  • @Phaedrux

    Hi,

    Yes I uncommented the line.
    I did tests, but at the same time I have found another problem and I have to resolve it before.
    I will post this problem in the right category.

    Regards.


Log in to reply