Heater issues with RRF 3.x



  • OK, updated to RRF 3, few minor issues but got them mostly figured out, but the heaters are being an issue..

    heating hot end it over shoots by 5-10º c every time now -Tried doing a PID tune but it fails also as it takes like an hour to get to 140º let alone to 240º

    try to heat bed and it gets the "fault, bed heating too slow"

    Searched the internet but got no fixes.. any ideas? guessing it something simple I'm missing?

    thanks![alt text](Screen Shot 2020-06-21 at 5.42.36 PM.png image url)


  • Moderator

    What firmware version exactly? Should be 3.1.1. Send M115 to verify.

    Ideally you shouldn't be using a lower PWM duty cycle for PID tuning. Any specific reason for using P0.4?

    What are your heaters and thermistors? What duet board?

    Post your config.g



  • THANKS for the response!
    it's 3.1.1 now (was 3.0 at time of post, though no change)

    • FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 3.1.1 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-05-19b2

    Hot end heater and therm - E3D stock for Hemera
    Bed and therm - Fodgertech 12v 300x300x3mm alum/PCB plate with stock therm (honestly the thing heated pretty fast till update)

    The "P0.4" was just a copy paste thing. redid that, got both the bed and hot end to do a PID tune, but now where to put it? wont do a M500, gives an error. (rather have it in the Config.g anyway), Read that M307 doesn't work anymore? And, even with a PID tune, likely it'll still trip the overly sensitive setting?

    Curious?, Why isn't there a simple setting somewhere that you can adjust the duration and rise of temp for thermal protection like in Marlin? How are people getting their beds to heat up with 3.x.x? Can't imagine most beds heat fast enough to avoid this from happening? Guessing there is something I'm missing somewhere?

    Config.g included as a file ..LlamaCoreConfig.txt



  • OK, this seems to have fixed it? not sure if it's really the right way to do it or not? I just replaced the M307 line from the old 2.x.x firmware. did another PID tune and edited the 3 settings...

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 A68.2 C561.1 D2.6 B0 ;(replaced PID tuned?) PID after RRF3 install
    ;M307 H0 B0 S1.00 ;(Stock) disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.06e-8 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    ;M307 H1 B0 S1.00 ;(Stock) disable bang-bang mode for heater and set PWM limit
    M307 H1 A472.4 C288.9 D5.0 V12.1 B0. ; (replaced PID tuned) PID tuned after RRF3 install.


  • Moderator

    So you've got it PID tuned and it's working properly now?



  • @Phaedrux seems to be, heaters at least, now all the sudden homing isn't working correct, which I (thought) i'd fixed.. will play later.


Log in to reply