CR-10+Bondtech+Silicon Bed 450W+Microswiss...Help



  • Noob is in the house.
    Hello good people,

    in my country we have a saying, "I look like a donkey looking at a palace", and that is me in relation to the generality of the topics that take place in this forum.
    So far, I have been printing well with my CR-10 and with the upgrades that are seen in the title of this topic, but recently I bought a wifi duet and a bltouch. Well, that's how my problems started 🙂
    I have tried to understand the science in the reprap settings but I have not been able to succeed.
    I have my duet installedwith the CR-10 own connectors, and as an access point, programmed by a friend!
    Now my doubts:
    -should I use reprap config 2.0? 2.3-2.5 or 3?
    -Someone who has hardware configuration more or less like mine can pass me the settings? I'm really bad at programming! 😞
    -I have a 24V power supply- Is it okay to have 12V fans? I haven't changed the heatsink fan and it seems to work well !!!
    -What is VIN?
    -I get an error: Filename too long: cap = 120, dir = 0: www / name = R / AA3gKIDA4mT ...What is this thing? 😞

    Well, that's it for now .... I need a guru to help me! Someone?



  • @Hélder-Roch

    -should I use reprap config 2.0? 2.3-2.5 or 3?

    Depends on the firmware running on your board.

    -What is VIN?

    This is the voltage which comes IN, so 24 volts in your case.

    Cou can search here in forum for my username and config.g or similar. I sharedmy config form my cr10 recently. Or use the configtool and select the ender3, that gives you a very Good preset to start with. Be careful with my config I have a extention board.



  • Thanks for the quick help response.
    Well, I already tried to use the settings of ender3 with the necessary changes in the measurements of the bed etc. However, I don't know why, as I can't take the y-axis home. It moves slightly but does not go to the end switch! But I will try again with thie ender 3 settings. and see if I can tune. Or I will look for your settings. Tks



  • @Hélder-Rocha
    Post your homey.g. I had the problem that the movement in the home*.g files where not as wide as the bed is. So the head moved not enough to rech the bed. So I changed the movement to something which is a bit bigger than the actual bed, to make sure that it will travel enough.



  • mine also.... the config is like on x axis.

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Mon Jun 22 2020 14:46:20 GMT+0100 (Horário de Verão da Europa Ocidental)
    G91 ; relative positioning
    G1 S2 Z5 F6000 ; lift Z relative to current position
    G1 S1 Y-305 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 S2 Y5 F6000 ; go back a few mm
    G1 S1 Y-305 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 S2 Z-5 F6000 ; lower Z again
    G90 ; absolute positioning


  • Moderator

    @Hélder-Rocha said in CR-10+Bondtech+Silicon Bed 450W+Microswiss...Help:

    G1 S1 Y-305 F1800 ; move quickly to Y axis endstop and stop there (first pass)

    Change the y-305 to something larger like y-500. See if that helps. Update homeall.g as well.

    You should be using 2.05 firmware at least. This may also solve your filename too long error. Then when you are more comfortable you can update to version 3.1.1+



  • Ok... ill try that tomorrow. Its a bit late now.
    Tks a lot for the help....
    I will be here with more douts if you care to help I'll be thankful.



  • @Hélder-Rocha
    The file looks good. Do you have a endstop configured for y in your config.g?
    I have seen that in the past too, but I can not remember how I have solved it. 😒
    Do you see that the state of the switch changes when you trigger the switch with your finger? You can monitor the switch in the webui, the very last section on the navigation on the left.



  • well... one of my problems is that i have my printer in my garage. Its not here near me. My answer is a question! If the x and z are working, possibly with the endstop configured, was that suppose to appen in the y axis? I really dont know if the Y endstop is configured! Dont know how to do that! And where to do that! Remember that i am the chosen noob ... take it easy on me! 🙂



  • @Hélder-Rocha
    Im not close to my printer at the moment, too. And I forget always my fist name, my date of birth and 120% of the g-codes. 🙂 I will give you a hint tomorrow if nobody else jumps in till than. It is a good idea to have the printer close to you during the setup period. You will need that during the next days, I was there a view weeks ago... 😀



  • Take a look at https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches there is a section "testing" that may be helpfully too.

    The M574 is responsible for the endstops: https://duet3d.dozuki.com/Wiki/Gcode#Section_M574_Set_endstop_configuration



  • Allright Chriss...the problem with the y axis was that the connector was not well pluged on the board.
    My next step is understanding the config for the bondetech... ill chek yours for now and see if it runs ok



  • @Hélder-Rocha
    The bondtech should be a nobrainer. Calibrate the e-steps and you should be Good to go. 🤞
    I thing that the Bondtech is the only part at my printers which did not caused problems.



  • Ok, but there must be a common base on the values i should use in the beginning right? In the exemples i see, by several cr-10 users with bondetech, there are different values on de config!
    In the M569, the P3 is usualy refered to the extruder, right?
    In the M92, for the ender 3, the value for the steps/mm is 420, should i uset?
    M566, i beleabe is the jerk, is set 120.
    M203 max speed is 1200.
    M201 acceleration is 250
    M906 mootr current is 800.


  • Moderator

    The correct bondtech settings will depend upon what motor you are using. Are you using the stock creality extruder motor? Which port do you have it plugged into?



  • @Hélder-Rocha

    My reflex would say "yes" to all of your questions. I think that I have 482.5, so 420 is fine to start with. Follow the guide from the wiki, it explains very, very well how to do that. I, personally, would not play to much with the other settings, you can tune them when your stepper start to skip steps.



  • Yes, is the stock one from cr-10. dont realy know what do you mean with port, but it suppose to be connected to the E0 Stepper in the board



  • @Chriss Tks Chriss... ill try then



  • Hi good fellows,

    allready have my printer working, but, at the momment i have 3 problems:

    1-Its printing too slow
    2-At the end of the printing, the extruder stays on top of the printed object.
    3- The fan for the noozle does not start after the first layer.

    I already encreased the acelleration to 1000 on x and y but i dont see much difference.
    I slice using Cura, and i was checking for possible problems with this slicer, and some guy said the slow problem have to do with a few lines in the beggining of the g-code, that he needs to erase! But he does not specify what lines are!!! Any place where i can check about cura settings to work with duet?
    Tks


  • Moderator

    @Hélder-Rocha it's in the start gcode section for the printer profile in Cura.

    Google Cura start gcode if you can't find it.

    When you're there you can also change the end gcode to move the print head up and away from the print.

    Can you control the part cooling fan with the slider in dwc?



  • @Hélder-Rocha said in CR-10+Bondtech+Silicon Bed 450W+Microswiss...Help:

    2-At the end of the printing, the extruder stays on top of the printed object.

    Change your "stop.g" and tell the printer there what to do after the print. 😉

    My look like that:

    M400			; Finish move queue
    G91			    ; Relative positioning
    G1 E-20			; Retract filament 20mm
    M104 S0 		; Extruder heater off
    M140 S0 		; Bed heater off
    ;M106 S255 		; Fan at 100 to cool nozzle and bed
    M220 S100		; Set speed factor back to 100% in case it was changed
    M221 S100		; Set extrusion factor back to 100% in case it was changed
    G1 Z15			; raise nozzle 15mm from printed part
    G1 Y255 F3000   ; Drive the bed forward
    


  • If you want to use stop.g on the duet rather than the end gcode in cura, you need to add M0 in the end gcode in cura otherwise stop.g won't get called



  • Hi guys, fist of all, thankyou very much for the help. Im sorry but the last few days ive been working out and has been impossible for me to check this forum.

    Chriss, the end of my g.code for a test cube on cura is like this:

    ;TIME_ELAPSED:2011.898237
    G1 F2700 E-3
    M140 S0
    M82 ;absolute extrusion mode
    M107
    G91 ;Relative positioning
    G1 E-2 F2700 ;Retract a bit
    G1 E-2 Z0.2 F2400 ;Retract and raise Z
    G1 X5 Y5 F3000 ;Wipe out
    G1 Z10 ;Raise Z more
    G90 ;Absolute positionning

    G1 X0 Y300 ;Present print
    M106 S0 ;Turn-off fan
    M104 S0 ;Turn-off hotend
    M140 S0 ;Turn-off bed

    M84 X Y E ;Disable all steppers but Z

    M83 ;relative extrusion mode
    M104 S0
    ;End of Gcode
    ;SETTING_3 {"extruder_quality": ["[general]\nversion = 4\nname = Dynamic Quali
    ;SETTING_3 ty #2\ndefinition = creality_cr10\n\n[metadata]\nquality_type = a
    ;SETTING_3 daptive\nposition = 0\ntype = quality_changes\n\n[values]\ncoast
    ;SETTING_3 ing_enable = True\nmaterial_print_temperature = 220\nretraction_amo
    ;SETTING_3 unt = 3\nretraction_extrusion_window = 6\nspeed_print = 60\n\n"],
    ;SETTING_3 "global_quality": "[general]\nversion = 4\nname = Dynamic Quality
    ;SETTING_3 #2\ndefinition = creality_base\n\n[metadata]\nquality_type = adap
    ;SETTING_3 tive\ntype = quality_changes\n\n[values]\n\n"}

    However, the printer doesnt do nothing, and it stays stoped on top of the print.
    As Jay_s_uk said, is it possible to for a conflit between this G.code from cura and a Stop.G on the duet? If it is, i cant find that stop.g in the duet config!

    Phaedrux, "Can you control the part cooling fan with the slider in dwc?" i cant even make the fan tests with the macros i have, but, for the momment, thats not a problem. The speed is what is troubelling me for now.

    Sorry for my gramatics...
    Best regards



  • @Hélder-Rocha

    Phaedrux describes stop.g here:
    https://forum.duet3d.com/topic/6760/stop-g/2

    I think that you do not have the "M0" in your endcode in your slicer. 😉 You can test your code fist by adding it the the endcode of your slicer for testing.

    Cheers, Chriss



  • Tks Chriss.
    How you know, when we find ourselfs a bit lost, we have to solve one problem at the time. For now, i wold like to find what is making my printer so slow. On the web panel i find the speed between 8 and 12 mm/sec. I have Cura 4.6.1 and g.code is reprap flavor. Do you know how can i make the printing faster?


Log in to reply