Event log doesn't want to start 3.1.1 Duet3 + SBC



  • Hi!

    I have quite strange issue. I wanted to start logging events, but I always get start/stop information.

    2020-06-23 14:17:38 Event logging started
    2020-06-23 14:17:38 Event logging stopped
    2020-06-24 09:47:04 Event logging started
    2020-06-24 09:47:04 Event logging stopped
    2020-06-24 09:47:08 Event logging started
    2020-06-24 09:47:08 Event logging stopped
    2020-06-24 09:47:11 Event logging started
    2020-06-24 09:47:11 Event logging stopped
    

    I've tested RRF3-RC12 and RRF3.1.1 but it doesn't work.

    It sounds similar to this topic: https://forum.duet3d.com/topic/16774/reset-during-print-duet-3-3-1-1-sbc?_=1592985911821
    but in my case printer works perfectly.

    Initially I was using M929 S1 in config.g file then I tried to start it manually but without good results.
    I suspected that some gcodes in config.g file can change RRF firmware behaviour and it casues problems, but then I tried to run firmware with empty config.g file but this problem still exist.

    @dc42
    I looked at the code and did small investigation
    When I execute M929 I always get "disabled" result

    8a6e9d02-1ca0-4b36-9ff8-5510c9926e2a-image.png

    Only Platform::Exit and RepRap::EmergencyStop can stop logging, but this scenario is no possible because my printer works perfectly.
    Is it possible that firmware can't create an logger object?

    Thanks!


  • Moderator

    What duet are you using? If Duet 3 are you using an SBC? And if using the SBC are you sure you're all up to date?



  • @Phaedrux I have Duet3 6HC + 3HC + RPi 4.
    I upgraded firmware on SBC using apt-get so it is official repo - RRF 3.1.1 (2020-05-19b2)

    I've already tested this same firmware on Duet2 Ethernet(without SBC) and logging works perfectly.

    Is SBC guilty?



  • @Phaedrux I have next weird observation.

    I don't use M929 S1 in config.g file, but after restart firmware when I send M929(without S param!) I get information that logging is "enabled".
    I checked eventlogs.txt file but file is empty.
    If I send manually M929 S1 I always get information that logging is "disabled".

    Duet2 Ethernet (RRF 3.1.1) works ok.
    Duet3 6HC + 3HC + SBC (RRF 3.1.1) is not able to logging data.



  • Any ideas?



  • It is a known limitation with DSF and some opertaions requiring SD card access so I'm guessing this falls under the same category and will work once that issue is resolved. I don't know when that is expected to be

    But if you tell us what you want to achieve I'm sure we can find a work around while we wait, the SBC does open other possibilities.


  • Moderator

    Sorry I missed your earlier replies, I'll raise the logging issue with @DC42.



  • I'd like to add that I am experiencing the same issue - Currently running current code on a Duet3 6HC (SBC Pi4 4GB) + 3HC + 4 x tool boards with distro board. Upon powering on the system the eventlog.txt records:

    2020-07-24 16:21:59 Event logging started
    2020-07-24 16:21:59 Event logging stopped

    Here I issued a manual M929 S1

    2020-07-24 19:21:31 Event logging started
    2020-07-24 19:21:31 Event logging stopped


  • administrators

    Thanks for the bug report. I could reproduce this problem and it will be fixed quite soon.


Log in to reply