BL Touch Issues RR3



  • HI Team I have been through the forum and for the life of me i can not work this out.

    I just upgraded my firmware to RR3, and am having BL Touch issues.

    Duet2 V1.04 and The Latest firmware V3.1.1

    Upon start up the probe retracts and deploys without an issue.
    When i do a home all it will not deploy, and i have to power off the machine before it hits the bed.

    I have checked the wiring and am using Heater 3 as the signal wire as i did before.

    I will attach the Config.g and the homez & Deploy/ retract as i have seen in other posts.

    Your help would be greatly appreciated.

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Sat Jun 27 2020 19:54:19 GMT+1000 (Australian Eastern Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Tevo Tarantula" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X200 Y200 Z200 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"!xstop" ; configure active-high endstop for low end on X via pin !xstop
    M574 Y1 S1 P"!ystop" ; configure active-high endstop for low end on Y via pin !ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Disable heaters H3-H7 to free up pins ; Added in Line To Disable heaters AK 27/06/2020
    M950 H3 C"nil" ; Added in Line To Disable heaters AK 27/06/2020

    ; Z-Probe
    M558 P9 C"^zprobe.in" H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    M950 S0 C"duex.pwm3" ; create servo pin 0 for BLTouch
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M556 S50 X0 Y0 Z0 ; set orthogonal axis compensation parameters
    M557 X15:200 Y15:195 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.06e-8 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M575 P1 S1 B57600 ; enable support for PanelDue
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss

    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Sat Jun 27 2020 19:54:19 GMT+1000 (Australian Eastern Standard Time)
    M280 P0 S10 ; deploy BLTouch

    ; retractprobe.g
    ; called to retract a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Sat Jun 27 2020 19:54:19 GMT+1000 (Australian Eastern Standard Time)
    M280 P0 S90 ; retract BLTouch

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Sat Jun 27 2020 19:54:19 GMT+1000 (Australian Eastern Standard Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X15 Y15 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning
    Duet Wire.png



  • My lines for BLT using same wiring:
    M950 S0 C"exp.heater3" ; create servo pin 0 for BLTouch
    M558 P9 C"zprobe.in+zprobe.mod" H5 F600 T6000 ; set Z probe type to bltouch and the dive height + speeds

    So I think you need to swap the two lines and use the pin ref as I'm using.

    When testing homeing, raise your Z alot and just trigger the pin with your finger to avoid bed crashing. If it doesn't stop, then do powerdown.


  • Moderator

    Also verify that you actually have 3.1.1 installed by sending M115.
    Once verified send M98 P"config.g" and report any errors.



  • @archie-karagiannis when the bltouch is working you will have to set the G31 X and Y positions, otherwise you measure the bed at the wrong position and the correction will be wrong.



  • @hmortensen

    Thank you so much i replaced my lines with your and it worked a treat ..

    Thanks


  • Moderator

    @hmortensen said in BL Touch Issues RR3:

    +zprobe.mod

    @archie-karagiannis you can remove that part from the M558 line. It's not used by the BLtouch.



  • @JoergS5 Will do so Thank you



  • @Phaedrux ok thank you


Log in to reply