BLtouch issue



  • Hello, I'm having an issue with my Genuine BLtouch. For starters here is my setup.

    Duet 3 using RepRap 3.1.1
    SBC Raspberry pi 4B running DuetPi
    Genuine BLtouch
    Wired as instructed by the documentation, red->5v, yellow->out, black and brown connected and going to ground, white->in

    When I turn on my printer the bltouch deploys and retracts the probe, turning its red led off when deployed and on when retracted. When I send the deploy and retract commands these also work as expected. However after I home my X and Y axis I try to home my z axis I get the following "Error: Failed to enable endstops". I've tried switching from io7 to io4, adjusting the screw in the bltouch, changing the config file, making sure the extruder heater was off, same issue. One thing I have noticed is the Z probe status never seems to change from 0.

    I've gone threw just about everything I can find and could use a hand, config.g below.

    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Mon Jun 29 2020 01:54:12 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Duet 3" ; set printer name
    M669 K1 ; select CoreXY mode

    ; Drives
    M569 P0.0 S1 ; physical drive 0.0 goes forwards
    M569 P0.1 S1 ; physical drive 0.1 goes forwards
    M569 P0.2 S1 ; physical drive 0.2 goes forwards
    M569 P0.5 S1 ; physical drive 0.5 goes forwards
    M569 P0.4 S1 ; physical drive 0.4 goes forwards
    M584 X0.0 Y0.1 Z0.2 E0.4:05 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X160.00 Y160.00 Z320.00 E291.03 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1500 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X500 Y500 Z500 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"io0.in" ; configure active-high endstop for low end on X via pin io0.in
    M574 Y1 S1 P"io1.in" ; configure active-high endstop for low end on Y via pin io1.in

    ; Z-Probe
    M558 P9 C"^io4.in" H15 F120 T1400 ; set Z probe type to bltouch and the dive height + speeds
    M950 S4 C"io4.out" ; create servo pin 4 for BLTouch
    G31 P25 X0 Y10 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"temp0" Y"thermistor" T100000 R2200 B4200 ; configure sensor 0 as thermistor on pin temp0
    M950 H0 C"out0" T0 Q10.0 ; create bed heater output on out0 and map it to sensor 0
    M307 H0 A331.0 C785.5 D5.5 V0.0 S1.0 B0 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"temp1" Y"pt1000" R2200 ; configure sensor 1 as PT1000 on pin temp1
    M950 H1 C"out1" T1 ; create nozzle heater output on out1 and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    ;M143 H1 S350

    ; Fans
    M950 F0 C"out7" Q500 ; create fan 0 on pin out7 and set its frequency
    M106 P0 S0 H1 T45 ; set fan 0 value. Thermostatic control is turned on
    M950 F1 C"out8" Q500 ; create fan 1 on pin out8 and set its frequency
    M106 P1 S0 H-1 ; set fan 1 value. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F0:1 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ;legacy pid
    ;Computed PID parameters for setpoint change: P13.4, I0.482, D51.4
    ;Computed PID parameters for load change: P13.4, I0.949, D51.4

    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0 ; select first tool


  • Moderator

    @vishiano said in BLtouch issue:

    "Error: Failed to enable endstops".

    Post your homing files please.

    Use M115 to verify that you are actually running 3.1.1
    Then send M98 P"config.g" and report any errors.



  • @vishiano said in BLtouch issue:

    M584 X0.0 Y0.1 Z0.2 E0.4:05

    not related to bltouch, but you have a missing dot here
    E0.4:05 => E0.4:0.5
    (probably makes no difference, just visually disturbed me)



  • @Phaedrux

    Here is M115

    7/2/2020, 6:45:58 PM M115
    FIRMWARE_NAME: RepRapFirmware for Duet 3 MB6HC FIRMWARE_VERSION: 3.1.1 ELECTRONICS: Duet 3 MB6HC v0.6 or 1.0 FIRMWARE_DATE: 2020-05-19b2

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Mon Jun 29 2020 01:54:12 GMT-0400 (Eastern Daylight Time)

    ;homez.g
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 Z505 F1800 ; move Z up until the endstop is triggered
    G92 Z500 ; set Z position to axis maximum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Mon Jun 29 2020 01:54:12 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-505 Y-505 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 H1 X-505 ; home X axis
    G1 H1 Y-505 ; home Y axis
    G1 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-505 F360 ; move slowly to X axis endstop once more (second pass)
    G1 H1 Y-505 ; then move slowly to Y axis endstop
    G1 H1 Z505 F360 ; move Z up stopping at the endstop
    G90 ; absolute positioning
    G92 Z500 ; set Z position to axis maximum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • @vishiano Only error from M98 is

    M98 P"config.g"
    Warning: M307: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 356C

    I have a separate issue with my heated bed which I believe to be unrelated to the BLtouch issue



  • @JoergS5 It bothered me enough that I fixed it 😁


  • Moderator

    Your homing files are set to use endstops for X Y and Z, but you have only defined endstops for X and Y.

    If you are using a probe for the Z axis, you need to change your homing files to use a G1 X Y move to position the probe, and then a G30 to probe the bed in place of this part:

    G1 H1 Z505 F360 ; move Z up stopping at the endstop
    G90 ; absolute positioning
    G92 Z500 ; set Z position to axis maximum (you may want to adjust this)
    

    Or, if you are using an endstop for the Z axis, you need to define it along with the X Y and Z here:

    ; Endstops
    M574 X1 S1 P"io0.in" ; configure active-high endstop for low end on X via pin io0.in
    M574 Y1 S1 P"io1.in" ; configure active-high endstop for low end on Y via pin io1.in
    


  • @Phaedrux

    So something like the following for homez.g?

    G90 ; relative positioning
    G1 X250 Y250 ;move probe to center of bed
    G30 ;probe bed

    Only thing is this lowers the bed down instead of up.



  • @vishiano I raised the bed and changed a line in my config.g

    G31 P0 X0 Y10 Z2.5 ; set Z probe trigger value, offset and trigger height

    Now when I run homez.g the BLtouch deploys and I get

    G28 Z
    Error: Z probe already triggered at start of probing move
    Error: Homing failed


  • Moderator

    Try G31 p25 instead of p0.

    If the bed is going the wrong way change the direction of the z axis rotation in m569.



  • @Phaedrux That did it, thanks for the help.


Log in to reply