Print artifacts



  • What i bet is happening.
    Weird extrusion.png
    The prints are unuseable.
    f0e5278e-e5e1-4171-b550-f1b15ddced47.jpg
    Tweaking the extrude startpoints gives abit better results.
    Still not even close.
    Missing 5mm of extrude on wall 2 on the outside, does a weird loop.
    d41151aa-2e9b-48c4-9f98-73eb1143990b.jpg

    Hot end and extruder are calibrated these problems are on nozzles 0.6mm and larger, test prints are printed on ApolloX 255°C nozzle, 95°C bed,50°C enclosure, print speed set to 12-24mm/s mooves are on 24mm/s, 1.2mm nozzle.

    Layer adhesion is good and the parts are stong.

    What can i do to extrminate the holes and the seam.

    Things i have tried.
    -Wipe settings, 5.2mm does something.
    -Coast settings, if coasting is on the results are worse.
    -Print speed, does nothing ofc over 40mm/s gets layer adhesion problems.
    -Retract settings, does absolutely nothing.
    -Temps are spot on.

    Using Cura slicer 4.6.1, i dont mind changing if there is something better out there, since this is most likely a slicer problem.



  • Is it a Bowden setup? If so, have you applied pressure advance ?



  • Its a direct drive.


  • Moderator

    Post your config.g so we can see your speed settings.

    What retraction settings are you using?

    Are you using pressure advance?

    Is the tube supposed to have a gap between walls?

    Can you share a saved .3mf file form cura so we can see your model and print settings?



  • These problems are only on cylinders, printed a pyramid as a test and no vetical lines, yes the cylinder has no infill.

    ; Drives
    M569 P0.0 S0 ; physical drive 0.0 goes backwards
    M569 P0.1 S0 ; physical drive 0.1 goes backwards
    M569 P0.2 S1 ; physical drive 0.2 goes forwards
    M569 P0.3 S1 ; physical drive 0.3 goes forwards
    M584 X0.0 Y0.1 Z0.2 E0.3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E409.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X15600.00 Y15600.00 Z180.00 E3600.00 ; set maximum speeds (mm/min)
    M201 X2800.00 Y2800.00 Z100.00 E250.00 ; set accelerations (mm/s^2)
    M906 X1900 Y1900 Z1900 E1197 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S120 ; Set idle timeout

    Allso what is this pressure andvance setting?


  • Moderator

    https://duet3d.dozuki.com/Wiki/Pressure_advance

    I suggest you try using firmware retraction so that you can adjust your settings while the print is running so you can see the results.

    I happened to be printing a similar type of object recently. An adapter to go from one size cylinder to another. The model was a solid wall, no gap between like you have. I also found there was a bit of a gap at the start of the next layer. Cura was set to use 4 walls, inner wall first, and then outer wall. Retract on layer change was set. To get rid of the gap I had to use slower unretract than I was using for retraction and then add a slightly amount of extra prime amount.

    There macros may help you in your real time tuning.

    https://forum.duet3d.com/topic/6181/tuning-macros-menus-accel-jerk-retraction-pressure-advance



  • Thanks, allso found out that stratasys has a patent for ''intelligent'' tool paths, it just basicly overlaps the ends so there is no gap, how can one justify to patent a sring of gcode is beyond me.

    https://patents.google.com/patent/US8349239B2/en


Log in to reply