Turning on fan on temperature reached



  • Hi,

    I am configuring a duet3 and I have a 2 wire hotend fan on OUT7.

    I am trying to get it to turn on only when the hotend reaches 45degrees, but that is not happening.

    Here's my config.g

    ; General preferences
    G90                                          ; send absolute coordinates...
    M83                                          ; ...but relative extruder moves
    M550 P"Duet 3"                               ; set printer name
    M669 K1                                      ; select CoreXY mode
    
    ; -----------------------
    ; Drives
    M569 P0.0 S0                                 ; physical drive 0.0 goes backwards
    M569 P0.1 S0                                 ; physical drive 0.1 goes backwards
    M569 P0.4 S0                                 ; physical drive 0.4 goes forwards
    M569 P0.5 S0                                 ; physical drive 0.5 goes forwards
    M569 P0.3 S1                                 ; physical drive 0.3 goes forwards
    M584 X0.0 Y0.1 Z0.4:0.5 E0.3                     ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                      ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E420.00            ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00          ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00      ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00          ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800                     ; set motor currents (mA)
    M84 S0                                       ; Disable motor idle current reduction
    
    ; -----------------------
    ; Axis Limits
    M208 X0 Y0 Z0 S1                             ; set axis minima
    M208 X230 Y210 Z200 S0                       ; set axis maxima
    
    ; -----------------------
    ; Endstops
    M574 X1 S1 P"!^io1.in"                       ; configure active-high endstop for low end on X via pin !^io1.in
    M574 Y1 S1 P"!^io0.in"                       ; configure active-high endstop for low end on Y via pin !^io0.in
    M574 Z1 S2                                   ; configure Z-probe endstop for low end on Z
    
    ; -----------------------
    ; Z-Probe
    M950 S0 C"io7.out"                           ; create servo pin 0 for BLTouch
    M558 P9 C"^io7.in" H5 F120 T6000             ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X37 Y-25 Z3                         ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20                     ; define mesh grid
    
    ; -----------------------
    ; Heaters
    M308 S0 P"temp0" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin temp0
    M950 H0 C"out0" T0                           ; create bed heater output on out0 and map it to sensor 0
    M307 H0 A81 C106.8 D0.9 S1.0 V24.0 B0		 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                      ; map heated bed to heater 0
    M143 H0 S120                                 ; set temperature limit for heater 0 to 120C
    
    M308 S1 P"temp1" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin temp1
    M950 H1 C"out1" T1                           ; create nozzle heater output on out1 and map it to sensor 1
    M307 H1 B0 S1.00                             ; disable bang-bang mode for heater  and set PWM limit
    
    ; -----------------------
    ; Fans
    M950 F0 C"out7" Q100                     	; create fan 0 on pin out7 and set its frequency
    M106 P0 S0 H1 T45                            ; set fan 0 value. Thermostatic control is turned on
    
    M950 F1 C"out8" Q500                         ; create fan 1 on pin out8 and set its frequency
    M106 P1 S1 H-1                               ; set fan 1 value. Thermostatic control is turned off
    
    ; -----------------------
    ; Tools
    M563 P0 S"e0" D0 H1 F1                       ; define tool 0
    G10 P0 X0 Y0 Z0                              ; set tool 0 axis offsets
    G10 P0 R0 S0                                 ; set initial tool 0 active and standby temperatures to 0C
    
    

    A big part of the code was generated in the configuration wizard.

    Any Ideas?

    Thank you



  • @knoker Try M106 P0 S1 H1 T45



  • @aidar I realize the mistake now... I was setting the speed to 0 when it reached 45ยบ....
    I'm not sure if I changed that or I pasted it directly from the config ui....

    Well, solved thanks a lot ๐Ÿ™‚


Log in to reply