PrusaSlicer defaulting speed at 8mm/s



  • ; generated by PrusaSlicer 2.2.0+linux-x64 on 2020-07-15 at 04:46:21 UTC

    ;

    ; external perimeters extrusion width = 0.45mm
    ; perimeters extrusion width = 0.45mm
    ; infill extrusion width = 0.45mm
    ; solid infill extrusion width = 0.45mm
    ; top infill extrusion width = 0.40mm
    ; support material extrusion width = 0.35mm
    ; first layer extrusion width = 0.42mm

    M201 X9000 Y9000 Z500 E10000 ; sets maximum accelerations, mm/sec^2
    M203 X500 Y500 Z12 E120 ; sets maximum feedrates, mm/sec
    M204 P1500 R1500 T1500 ; sets acceleration (P, T) and retract acceleration (R), mm/sec^2
    M205 X10.00 Y10.00 Z0.20 E2.50 ; sets the jerk limits, mm/sec
    M205 S0 T0 ; sets the minimum extruding and travel feed rate, mm/sec
    M107
    M190 S60 ; set bed temperature and wait for it to be reached
    M104 S210 ; set temperature
    M109 S210 ; set temperature and wait for it to be reached
    G21 ; set units to millimeters
    G90 ; use absolute coordinates
    M82 ; use absolute distances for extrusion
    G92 E0
    G1 Z0.350 F7800.000
    G1 E-2.00000 F2400.00000
    G92 E0
    G1 X145.842 Y77.467 F7800.000
    G1 E2.00000 F2400.00000
    G1 F1800.000
    This is the beginning of my sliced Gcode. Why is it going so slow ?



  • I think you have PrusaSlicer set to gcode_flavor Marlin. Change this to RepRap, and hopefully it will no longer apply those machine limit commands to your Gcode.

    RRF M203 is in mm/min, not mm/sec. Marlin must use mm/sec.


  • Moderator

    @mrenz999 said in PrusaSlicer defaulting speed at 8mm/s:

    M201 X9000 Y9000 Z500 E10000 ; sets maximum accelerations, mm/sec^2
    M203 X500 Y500 Z12 E120 ; sets maximum feedrates, mm/sec
    M204 P1500 R1500 T1500 ; sets acceleration (P, T) and retract acceleration (R), mm/sec^2
    M205 X10.00 Y10.00 Z0.20 E2.50 ; sets the jerk limits, mm/sec
    M205 S0 T0 ; sets the minimum extruding and travel feed rate, mm/sec

    These commands are overriding the values set in config.g. As @bot said, change the gcode_flavour (in Printer Settings > General > Firmware > G-code flavor). If set to Marlin, there's an extra option 'Machine limits', where the settings create the above code. Set to 'RepRap/Sprinter' and it shouldn't put these settings in the start gcode.

    Ian


Log in to reply