g2/g3 outside machine limits on every arc



  • Hi,

    I'm testing my vinylcutter toolhead so my printer isnt in normal working order, but until today all my test files were executed without any issues, now im getting this arc error.

    there are g3 commands in the gcode file (generated by the inkscape plugin "gcodetools" like this one: "G03 X23.644211 Y21.454407 Z-0.200000 I-27.848980 J-58.229755 A-3.5028857717"

    my delta radius is at 200 that that shouldnt be an issue as well.

    no matter where the first g3 happens in the file the printer immediately stops. i tested a few different designs but no arc will execute.

    im not sure what happened from yesterday to today that could cause this changed behavior.

    Board: Duet WiFi 1.02 or later (duetwifi102)
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.05.1 (2020-02-09b1)
    Duet WiFi Server Version: 1.23
    DWC 3.1.1



  • @sungod3k maybe because there is no A parameter in G3:
    https://duet3d.dozuki.com/Wiki/Gcode#Section_G2_G3_Controlled_Arc_Move
    Is a an additional axis?

    I don't find any A parameter, even not in the inkscape / gcodetools discussions. You may have added it somehow in the software and it is unknown to be interpreted.


  • administrators

    What were the X, Y and Z coordinates at the start of that G3 command? What are your M208 Z limits?


  • Moderator

    @sungod3k said in g2/g3 outside machine limits on every arc:

    G03 X23.644211 Y21.454407 Z-0.200000 I-27.848980 J-58.229755 A-3.5028857717

    It's the 'Z-0.200000' that's stopping it, because it's an absolute move below the bed level, and probably the machine limit set by M208 in your config.g. Starting at X23.644211 Y21.454407 (because you need to start at a point on the circle, and you didn't give the G1 command prior to the G3 command), if I send the full command I get "Error: G2/G3: outside machine limits". If I send without the Z parameter, it draws a full circle, just inside my machine limits. The A parameter seems to be ignored. I'm using a Cartesian machine with X0 Y0 in the centre, bed size is roughly 220x220. M208 Z minimum is set to Z0

    If you want your machine to go to Z-0.2, set it with M208 Z-0.2 S1. If I do this, the full command then works.

    Ian


  • Moderator

    @sungod3k It looks like the A parameter is actually for an additional rotation axis, presumably so the cutter can be orientated to the correct direction for cut. I don't know if RRF can accept this input; afaik it only accepts XYZE movement inputs. I'd guess that you've selected something in gcodetools that defines this. Do you need the A axis?

    Ian



  • @droftarts said in g2/g3 outside machine limits on every arc:

    M208 Z-0.2 S1

    Yes that works! I had tried something similar with M564, but M208 seems better suited.



  • @droftarts

    No, the cutter orients itself.

    The dragging of the knife is actually working surprisingly well. It doesnt produce perfect 90deg corners but its not barely noticeable.


Log in to reply