v3.1 cannot connect with android browser or app



  • Hello, So I have two printers an Artemis 300 running v2.02 and an ender 3 pro I put a duet 2 wifi in with v3.1.1. Everything works on my ender controlled through my PC. I can connect to both with my PC(eithernet), but can only connect to the 2.02 one with my cellphone(or any tablet or phone). I disabled my 5ghz network so everything is connected to 2.4. cleared cache on my phone. Downloaded "Find My Duet" and it doesn't find either of them. Does 3.1.1 not support mobile? I wanted to use this extra tablet as a screen for my ender but cant get anything mobile to work. Any help would be great, can upload whatever files need looked at. Thanks



  • @woabash 3.1.1 on a duet3 works for me from mobile. It's also found by FindMyDuet.


  • administrators

    I sometimes have to type http:// explicitly before the IP address, otherwise the browser wants an https connecion.



  • Can you access it by its IP address? Again try specifying http://192.168.n.n/ or whatever the IP is. Send M552 to the g-code console on the Duet to find the IP, or look in your routers client list.

    Also check that your phone is is in the same IP address range/subnet as the Duet, the app and mDNS will not work across routed networks. I.e. Duet with IP 192.168.1.2 and phone with ip 192.168.1.3 should work - but if the phone had, say, 192.168.2.3 the app, name resolution and direct IP connection might not work.

    And in the end using the name does require support in the client as well as the Duet, so the make, model and firmware version could be relevant to try and find out if the client support mDNS (but most likely it will)



  • Tried the putting http in front, no go. I only use IP's when trying to connect. Both my printers are connected to the internet according to my connected devices page for my router on 2.4(my 5g is disabled while I'm working on this)Plus they are both working with my PC. I know their IP's and both dont have https in front.

    UPDATE: My Artemis is now doing the same thing so IDK whats happening, it not just my phone because I've tried others. I know they both are on the network this is just strange.

    Have no idea what to do now lol



  • Just putting it out there in case someone has the same problem. Comcast xfinity has new thing where you have to log into their website(not the modem settings site) to turn off and separate the 5g from 2.4g. So I did that and reset the modem like 5 times and now everything connects great. 👍 👍 👍


Log in to reply