Maestro 3.31 BL and homing issues?!!



  • Hi guys.
    I just upgraded my machine with new heatbed, 2 z motors with screw all through and a Hemera. Upgraded to 3.31. I can't seem to get the 2.0 Bltouch working properly, its not deploying (didn't change the wiring, same as before) and for some strange reason when I HOME ALL the head is not going all the way to the left, it is down but not to the left!!!

    ; Configuration file for Duet Maestro (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Wed Jul 29 2020 16:30:43 GMT-0230 (Newfoundland Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Crapster 4.0" ; set printer name
    M669 K1 ; select CoreXY mode
    M918 P1 E4 F2000000 ; configure direct-connect display

    ; Network
    M552 P192.168.2.70 S1 ; enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E400.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z100.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X320 Y320 Z300 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M950 S0 C"^zprobe.mod" ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H5 F100 T2000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X60 Y-30 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • Oh and whats the gcode is ignore the Home all so I can do some more testing?


  • Moderator


  • Moderator

    @cabal2000 said in Maestro 3.31 BL and homing issues?!!:

    M950 S0 C"^zprobe.mod" ; create servo pin 0 for BLTouch

    You don't mention what pin you're actually using for the BLtouch servo control, but it's probably heater pin 3 or 7.

    So instead of ^zprobe.mod it should be exp.heater3 or exp.heater7



  • I scraped 3.31 and back to 2.05. must everything is working BUT the homing!!


  • Moderator

    Well the bltouch pin was one thing to change.

    I didn't understand the comment about to the left. Can you be more descriptive of the problem?

    Also post your homeall file.



  • @Phaedrux Sure!! When i home my CoreXY the head always always travels left and stops at the endstop, then it travels to the front of the printer, left corner to get x0 y0. BUT for some strange reason its not going left, just to the front


  • Moderator

    Well I'd need to see the homeall certainly as well as the physical position of the endstops. (left and front by the sounds of it, which matches your M574 endstop definition).

    For Corexy you should check the motor direction using this method

    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCoreXYPrinter#Section_Testing_motor_movement


Log in to reply