Move Extruder motor with Feedrate?



  • How do I move the extruder motor with a Feedrate?

    I issued these commands:

    G1 E1 F5    ; even f50 does not help
    G1 Z.242 E44 F5
    

    With the first line, the extruder moves painfully slow. In the second one, the extruder moves at the desired rate.

    So, how do I get the extruder to move at the same rate in line one (only the extruder) as line two (both Z and extruder)? I have tried F50, and that does not change the extruder rate a noticeable amount.

    Thanks!



  • @tenaja That's down to how the firmware interprets the commands:

    G1 E1 F5
    

    Will extrude 1mm of filament at 5mm/min (RRF uses mm/min for speeds). As you are only commanding an extruder move, that sets the speed. So with F5, it will take ~12s!

    G1 Z0.242 E44 F5
    

    Will extrude 44mm of filament whilst the Z axis moves at a commanded speed of 5mm/min over a distance of 0.242mm. That will take ~3s, and you will be extruding 44mm of filament, so your extruder would be moving at ~15mm/s (that's over 900mm/min so a lot faster than the first one!)

    All of this is also bound by what speed limits, accelerations and jerk settings you have for all of the moving axes (X, Y, Z, E etc) in your config, so your actual moves might be a bit slower/take a little longer depending on your settings.



  • @tenaja said in Move Extruder motor with Feedrate?:

    G1 E1 F5

    Thanks, but I already knew what you had posted--that is why I mentioned the F50 for the "e-only" move. (Literally, the comment "; even f50 does not help")

    To reiterate, why does this:

    G1 E1 F50
    

    Go at the same speed as this:

    G1 E1 F5
    

    I would expect the first to go 10x faster than with an F5. My max speed is set to E3200, and that should be moot anyway if it will go faster when the Z axis is moving.

    Thanks again!


  • Moderator

    @tenaja There's a minimum feedrate per axis of 0.5mm/s or 30mm/min. See https://duet3d.dozuki.com/Wiki/Gcode?revisionid=HEAD#Section_M203_Set_maximum_feedrate

    If you send M203 I5, it will reduce the minimum feedrate to 0.08mm/s or 5mm/s.

    Ian



  • @engikeneer said in Move Extruder motor with Feedrate?:

    All of this is also bound by what speed limits, accelerations and jerk settings you have for all of the moving axes (X, Y, Z, E etc) in your config, so your actual moves might be a bit slower/take a little longer depending on your settings.

    @tenaja said in Move Extruder motor with Feedrate?:

    My max speed is set to E3200, and that should be moot anyway if it will go faster when the Z axis is moving.

    The max feedrate of any axis is a hard limit.

    Because everything needs to stay in sync, the printer will try and move at the feedrate set, but it will be limited by each axis max feedrate involved.
    You can see this if you do silly things like drop the E max feed rate really really low.
    If your extruder max feedrate is actually based on a real tested value, it can actually be helpful to prevent failures.
    People also sometimes see it when they have a very slow Z axis when using self-leveling.

    If we are following G-code conventions correctly, a G0 command doesn't bother with syncing the axies but just goes to the target at as close to the feedrate as each axis can manage. As opposed to G1 etc.


  • Moderator

    @theruttmeister said in Move Extruder motor with Feedrate?:

    If we are following G-code conventions correctly, a G0 command doesn't bother with syncing the axies but just goes to the target at as close to the feedrate as each axis can manage. As opposed to G1 etc.

    It's a little different in RRF: https://duet3d.dozuki.com/Wiki/Gcode?revisionid=HEAD#Section_G0_G1_Move

    RepRapFirmware treats G0 and G1 in the same way 'except as follows:

    On SCARA and similar architectures that normally require linear motion to be approximated by short segments, a single continuous non-segmented movement will be used if this can be done without the print head dropping below the current Z height.
    In Laser and CNC mode, G0 moves are executed at the maximum feed rate available, to comply with the NIST GCode standard, This feed rate is set by the M203 command.


Log in to reply