FLSun QQ-S Pro - Level Sensor reads 1000 when axis homed



  • Have connected the Z-Probe that comes with the QQ-S Pro to the Z probe connector on the Duet 2 WiFi. The DWC is showing a value of 1000, if I press the button on the sensor, the value goes to zero. I have tried using I1 with M558 also I0, but the value does not change. When I try to use delta calibration (G32) the sensor comes down to roughly 20mm from the bed, moves to a few points without changing height and shows a few errors (Error: Z probe already triggered at start of probing move). Have uploaded homedelta.g, config.g and bed.g for reference.

    Please feel free to treat me as an absolute beginner. Too much information is, well, never too much. Thanks.
    homedelta.g config.g bed.g


  • Moderator

    It would help to know your firmware version. Send M115 to find out. Should be either 2.05.1 or 3.1.1

    Your config has the syntax for RRF3, but maybe your firmware doesn't match.


  • Moderator

    @PeteL Your config.g is set up for RepRapFirmware 3. If you are using RRF 3 (send M115 to the Duet to check), don't use I1 to invert the probe, use ! in the pin name. Currently your Z probe command in config.g looks like:

    M558 P1 C"zprobe.in" I0 H30 F120 T6000              ; set Z probe type to unmodulated and the dive height + speeds
    

    Change it to:

    M558 P1 C"!zprobe.in" H30 F120 T6000              ; set Z probe type to unmodulated and the dive height + speeds
    

    For more information, see M558 and https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe

    Ian



  • @Phaedrux Thanks for the response. Checked firmware version: FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 3.1.1 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-05-19b2



  • @droftarts Thanks for the response. This worked brilliantly. The '!' is listed on the M558. Note to self... read more! 🙂
    Thanks again.
    Pete.


Log in to reply