M117 Error following upgrade to 3.1.1



  • Re: M117 Bad Command
    Hi all,

    I updated one of my machines to 3.1.1 yesterday. I am getting some curious issues with M117. If I leave the string unquoted [as indicated in the Reprap documentation wiki] the command returns an error
    9f248353-61f2-4b72-9563-de0f81db368d-image.png .
    However if I quotation wrap the string then the returned message loops endlessly.
    M117 Msg repeating (Quotations used).png .
    The only way I can clear this is to restart the machine.

    Not a major issue but it would be good to see what I might be getting this wrong.



  • @oddjob said in M117 Error following upgrade to 3.1.1:

    If I leave the string unquoted [as indicated in the Reprap documentation wiki] the command returns an error

    but it works with quotes? that could be a RRF3 thing as some other command needs quotes in RRF3 but didnt in RRF2.



  • Hi,
    Yes M117 works with quotes but the returned message then loops. Which requires an reset to halt.



  • My initial post was not the best formatting. I had addditional comments nested between the 2 attachements.



  • Hi all,

    It seems that 3.1.1 doesn't like the old web interface. If I run the latest version of DWC M117 is fine. Again if I choose the revert to old DWC option M117 returns errors or loops.


  • Moderator

    @oddjob The old web interface is untested and unsupported with RRF 3. It works, but there may be glitches. For this one, try using M118 rather than M117.

    Ian


Log in to reply