M117 Bad Command



  • Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.01-beta3 (2020-01-29b1)
    Duet2 Ethernet

    I have been getting errors in scripts randomly that use the M117 command. Some work. Some don't.
    m117.png



  • Try using double quotes around the message as in
    M117 "purging material"



  • It is indeed in the simplify 3d Start script:

    ; Ender 5 Custom Start G-code
    
    M80; Turn on Printer
    M117 Pre-heating Bed
    M140 S[bed0_temperature] ; Set Heat Bed temperature
    M190 S[bed0_temperature] ; Wait for Heat Bed temperature
    M117 Pre-heating extruder
    M117 Heating extruder
    M104 S[extruder0_temperature] ; Set Extruder temperature
    G28 ; Home all axes
    M117 Auto bed-leveling
    G29 ; Auto bed-level (BL-Touch)
    G92 E0 ; Reset Extruder
    M109 S[extruder0_temperature] ; Wait for Extruder temperature
    
    G1 Z1.0 F3000 ; move z up little to prevent scratching of surface
    G1 X0.1 Y20 Z0.3 F5000.0 ; move to start-line position
    
    M117 Purging Material
    G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; draw 1st line
    G1 X0.4 Y200.0 Z0.3 F5000.0 ; move to side a little
    G1 X0.4 Y20 Z0.3 F1500.0 E30 ; draw 2nd line
    G92 E0 ; reset extruder
    G1 Z1.0 F1500 ; move z up little to prevent scratching of surface
    M117 Printing
    
    ; End of custom start GCode
    

    However, the "Purging Material" lines seems to be the only one that the Duet complains about. Several of the other M117 commands execute just fine.



  • Just for curiosity sake, put the quotation marks around it and see what happens.
    I know it doesn't make sense but humour me, please !



  • Will do. I have a print still running for the rest of the day. I will try that as soon as this one completes.

    The only thing I see that makes that line unique is the blank line before it??



  • Yes, I have noticed that as well. The reason I am asking you to run that line with quotes is because I had a similar issue where some M117 commands without quotes didn't work and then worked fine once quoted. According to DC42, both quoted and unquoted should work (and they do for you) but since I have seen the weirdness before, I think it is worthwhile testing it.


  • Moderator

    I dunno what happened to me in my formative years, but having a string WITHOUT quotes makes me nervous.


  • administrators

    @mitch, please can you post (either here or on a file sharing site such as Dropbox) a GCode file that demonstrates the problem, so that I can try to reproduce the problem and fix it.

    I have already tested that your failing M117 line preceded by a blank line works for me.



  • @dc42

    Will do. I am on travel so it may be a few days but happy to post a file with the issue when I return.



  • eyeball4_2 trunkcated.gcode

    I truncated the file to meet the upload limit but here is the offending file. same error on that same M117 line every print.

    I haven't tried with quotes. Pretty confident that would fix it. But I get that it should work both ways and you want to see why is causing the problem. Much appreciated.

    thanks


Log in to reply