Duet2Wifi - Burnt the E0 controller



  • Hi all,

    A few months ago, I bought our first 3d printer. I did some research and decided, price-wise, on an Ender3 Pro.
    It was an instant success. I was in love. After some time, I felt I wanted to upgrade the motherboard. I really loved the web UI of the Duet and felt it was a good way forward.

    I did not do my research very well in this respect.

    I found a guide to upgrade an ender3pro with a Duet Maestro. When purchasing the Duet card, I decided it would be better to get the Duet2 Wifi instead. Not sure if this is a mistake or not.

    I ordered some additional upgrades (fillament end switch and a 3dtouch), to make the experience complete.

    Come the installation. A bit stressed. The printer is cheap, but not that cheap. The board is not cheap, I really didn't want to mess things up.

    Despite this, I did continue with the maestro tutorial and didn't look for a duet2WiFi tutorial. I think I made all the right extrapolations to make the right connections on the board. I did print a copy of the pin layout of the duet2Wifi to make sure I'm connecting all the right things

    After a week of intermittant tinkering, I was confident the setup was fine. I double checked all the wires and double checked all the connectors.

    Another thing may be worth mentioning is that I went with the direct extruder set-up. In order to be able to mount the extruder stepper motor on the hotend, I had to extend the supply wire. I extended the supply wire with dupont connectors and some loose wires from a cat6 ethernet cable.
    I checked the polarity of the stepper motor at least 6 times at the connector to the board to make sure the polarity was correct. I read I could fry the stepper motor if I was not careful and had interchanged pins.

    Come the configuration.
    I went through the configurator and compared the result with what I found online was a good idea for the Ender3 and with the configuration that was used for the maestro (I did notice the differences in the termomisters).

    Come the testing. I started up the device and all looked well. A nice web interface and after a few hours I got the ender3 homing in the right direction, without the 3dtouch. I'd configure it later. The fan test passed, the heating test failed with the macro (only bed heating worked), but when I activated the hot-end manually and tested it's heating, that worked as well. Sweet. I got a hot hot-end. Let's see if the extruder turns in the right direction.

    Extruder +10.

    poof - whisp of smoke rises from the board
    I can see the chip that says E0 now has a white burn mark.

    The web interface had this to say:
    Error: short-to-ground reported by driver(s) 3
    Error: short-to-ground reported by driver(s) 3
    Warning: high temperature reported by driver(s) 3
    Error short-to-ground reported by driver(s) 3
    Error: over temperature shutdown reported by driver(s) 3
    Warning: high temperature reported by driver(s) 3

    All-in-all this took 1-2 seconds. At the moment I had no idea what was going on.

    At this point I'm hoping I'm still going to be able to use the E1 stepper and still be able to use the board, but before I continue, I want to make certain I'm not breaking that one as well.

    What went wrong?



  • The config file:

    
    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Thu Aug 20 2020 14:32:34 GMT+0200 (Central European Summer Time)
    ; General preferences
    G90                                                ; send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    M550 P"Ender 3 Pro"                                ; set printer name
    ;M665 R105.6 L215 B85 H250                          ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0                                      ; put your endstop adjustments here, or let auto calibration find them
    M918 P1 E4 F2000000                                ; configure direct-connect display
    ; Network
    M552 S1                                            ; enable network
    M586 P0 S1                                         ; enable HTTP
    M586 P1 S0                                         ; disable FTP
    M586 P2 S0                                         ; disable Telnet
    ; Drives
    M569 P0 S0                                         ; physical drive 0 goes backwards
    M569 P1 S0                                         ; physical drive 1 goes backwards
    M569 P2 S1                                         ; physical drive 2 goes forwards
    M569 P3 S0                                         ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3                                   ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                            ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E93.00                   ; set steps per mm
    M566 X600.00 Y600.00 Z60.00 E300.00           ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z600.00 E6000.00        ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z120.00 E5000.00           ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E900 I30                    ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    ; Axis Limits
    M208 X0 Y0 Z0 E0 S1                                         ; set minimum Z
    M208 X235 Y235 Z260 S0
    ; Endstops
    M574 X1 Y1 Z1 S1                                   ; set active high endstops
    M591 D0 P1 C3 S1
    ; Z-Probe
    ;M307 H4 A-1 C-1 D-1                                ; disable heater on PWM channel for BLTouch
    ;M558 P9 H5 F120 T6000                              ; set Z probe type to bltouch and the dive height + speeds
    ;G31 P500 X42 Y15 Z2.5                                ; set Z probe trigger value, offset and trigger height
    ;M557 X10:225 Y10:225 S20                                       ; define mesh grid
    ; Heaters
    M305 P0 T98801 B4185 R4700                        ; set thermistor + ADC parameters for heater 0
    M143 H0 S80                                        ; set temperature limit for heater 0 to 150C
    M305 P1 T98801 B4185 R4700                        ; set thermistor + ADC parameters for heater 1
    M143 H1 S275                                       ; set temperature limit for heater 1 to 275C
    ; Fans
    M106 P0 S0 I0 F20 H-1                             ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F20 H1 T45                          ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F20 H1:0 T45                        ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ; Tools
    M563 P0 S"hotend" D0 H1 F0                                   ; define tool 0
    G10 P0 X0 Y0 Z0                                    ; set tool 0 axis offsets
    G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
    ; Custom settings are not defined
    M501
    ; Miscellaneous
    M911 S21 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    
    

  • administrators

    @fraksken It sounds like the wiring on your extruder motor could be different from the Duet stepper output. If you have a multimeter check which pins on the connector the two coils are connected to (there will be a low resistance between two pins):

    https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors#Section_Identifying_the_stepper_motor_phases



  • I've scheduled the wires to meet the pins in this picture alt text
    There indeed is a low resistance between two pins. I'm currently reading 4.2Ohm on both of the phases.


  • Moderator

    If you're confident you've identified the phase pairs of the motor and you're following that image to connect them you should be good to go.

    What it wired differently the first time?



  • Hi @Phaedrux,
    No, I was very careful to map out the 2 phases before connecting anything. I've must have confirmed about 6 times I was connecting the right wires.
    Looks like I'll be making another attempt on E1 next time I'm getting to it.
    I will report back.



  • So I finally had some time to look at the printer again.
    I've moved the connector from E0 to E1, adjusted the parameters in the config file and tested again.
    This worked, no problems. The extruder was extruding.
    Could it have been a faulty solder on the board?


  • Moderator

    @fraksken said in Duet2Wifi - Burnt the E0 controller:

    Could it have been a faulty solder on the board?

    Post some photos. Poor solder on the pins of the socket has happened before and would be quite noticeable, though it's quite rare.



  • Hi @Phaedrux

    I've opened up the case and took a picture of the chip.
    hope it'll bring some clarity.

    Thanks for looking into this.

    1024-2219.jpg


  • Moderator

    Yes that's definitely a burnt out driver chip.

    If you are using a single extruder you can map the spare extruder driver instead.

    Instead of M584 X0 Y1 Z2 E3
    it would be M584 X0 Y1 Z2 E4

    And add M569 P4 S0 and set S0 or S1 to match the correct direction of the extruder.


Log in to reply