IdeaMaker I really wanted to like it...



  • Im a simplify3d user have been for years

    After reading about the use case for ideamaker i thought "ok lets give it a try again"

    I had previously tried it and couldnt get a decent print, i was prepared to put that down to not knowing the software and I was willing to try again.

    So last month i setup some profiles and was tuning until i was at a point yesterday of thinking "I need to post on the duet forum that im a convert" i had eventually managed to tune supports to a point of where they would remove with minimal effort, i was so chuffed with the results i was getting i even showed my wife how easy it was now.

    Ah but it was not meant to last, windows update struck last night.....

    System had updated and the computer had restarted during the night

    i come to start a print i had just drawn up and when i get to ideamaker i get the "welcome screen" im like eh!!! so after a bit of checking ideamaker is back to stock no printer profiles, no filament profiles nothing, weird but ok I will just go and see if the profiles are still in the raise3d profile folder in appdata... Luckily they were.

    But ideamaker lists : Cannot import this template file............

    FFS

    So not to be deterred lets open a .data file from a sliced print from yesterday when all was working and import the settings.

    Ideamaker says NO............... : Access Denied

    So i have no option but to start again and build a new profile, i start that process and the g.code it produces gets to a corner and its adds 4mm on the retraction restart (even when retraction is turned off)

    I tried a "roll back" to an earlier time and still nope

    So back to simplify3d it is then, i know it shouldnt matter but the software shouldnt suddenly go haywire with a windows update. Simply3d didnt stop working...



  • @CaLviNx did you have a user change together with the windows update? Microsoft wants the users to convince to use cloud based users and in the past tried to convince me to change the user account and link it to my cell phone number. If you had a user change, the profiles will be changed where your user settings are stored, and may explain your trouble.

    Apart from that, is IdeaMaker worth a try, compared to being a Cura user? (only a short statement whether it's worth the effort)



  • @JoergS5

    No user change, I point blank refuse to login using an "on-line" account, which might piss them off!! It's always an offline account, and I only ever install critical updates.

    It's just strange that the update screwed with idea maker, only thing I can think of is because idea maker was still open and win 10 forced a close on it.

    What I can't understand is why ideamaker is now so corrupted.

    I uninstalled the program did a restart and a registry clean up after then tried a re-install and the program still won't work properly, even with its default settings so I'm not prepared to be messing around with it If it's not going to play nice.

    Before this issue I was a convert it was producing very nice quality prints and as I said once I got the retraction and support dialled in it was amazing. I might try it on another PC and see it it produces and different result, but only when I have a spare moment



  • @CaLviNx thank you for your feedback. I'll seach a bit in the internet whether I find a reason for your experience. It is a real pity, if the software is actually good.

    tried a re-install and the program still won't work properly

    You can try installing with administration right, some programs want to change registry or protected system folder files and need admin rights.

    There is an ideaMaker forum:
    https://forum.raise3d.com/viewforum.php?f=3&sid=2dbf9de2e91ccd5812990c742f67869d
    in case you don't know it.

    If you have still you old profiles, you could try this here:
    https://forum.raise3d.com/viewtopic.php?f=3&t=20832



  • @JoergS5

    My system is set so anything I do automatically has admin rights, i also have a
    "take ownership" script running

    I did a search on the raise forum and tried a few of the suggestions. the software is classing the profiles as "obsolete" for some reason and refuses to allow me to load them.



  • @CaLviNx I didn't find additional information in the internet, so I cannot help you further. I wish you success to set it up again.



  • @CaLviNx win10 here, a bunch of updates last few weeks, IM still working ok, no lost templates. I also do not want to login to m$, no cloud nor similar BS, just local stuff.

    On the other hand, I did manually save (and after some major changes I always change again) all the profiles as I had the experience you are mentioning but with s3d, I lost all my simplify3d profiles twice, so now no matter what slicer I use, if I make a profile that makes sense, I export it to a safe location. This is my suggestion for every slicer for every user. Just don't trust them, backup your settings from time to time. I never lost profiles on IM but who knows, maybe I will tomorrow (but I have backup 😄 ), I never lost config on CURA but if you look at facebook groups it comes up from time to time that ppl find their cura profiles corrupted, same with slic3r... never happened to me with any slicer but simplify3d but that's probably 'cause s3d is the silcer "with profiles" that I used the longest (skeinforge that I used before had no profiles but just a script to call it with a whole bunch of command line parameters so..).

    As for how to recover your profile data, my suggestion is to ping IM on their forum, they are pretty responsive.



  • Well Stubbornness took over...

    I did an install on my wife's P.C. and I got that to install but it wont allow me to import the original profiles.

    So back to my P.C. and I un-installed the program, did a registry clean again (re-booting after every step) manually deleted the app data folder and the Raise3d folder in windows program files, rebooted again and then installed the program again and did a full setup.

    I then got it to at least print without going nuts from a standard profile, but it wouldn't allow me to import the .bin template but it did allow me to import the slicing data from the saved .data file of an already sliced model.

    So it appears I am back to the start of the road again, what a bloody waste of a day.

    Windows Grrrrrrrr

    So all updates permanently stopped using group policy editor

    @arhi I have manually backed everything up lesson learned.

    @JoergS5 thank you for the assistance.



  • @CaLviNx I had more than 100 profiles in s3d for different materials, nozzles, extruders for my 4 printers when darn thing decided to corrupt them. From what I figured S3D keeps that all in windows registry. Was it the windows that corrupted the registry or S3D corrupted the data while writing no clue but I learned my lession and am now saving them externally. Not blaming S3D for that. Now, with S3D good thing is you can manually restore most of the settings (if not all) from the .gcode files if you saved those, IM on the other hand by default does not do that :(, you even have to manually add the comment for layer height so that RRF/DWC know what the layer height is.

    Now as for IM, I understand you managed to tune it perfectly and that you liked it :), I'm sure you will get there again after few prints 🙂

    If you did not open a thread on the reise3d forum, I suggest you do; not only so you figure out how to restore your profiles but also to warn others this crap can happen to them too, and maybe there's something IM could do in order for this to not happen again


Log in to reply